URL Not Found After Conerstone Update

HI I have recently updated Conerstone to the latest version and now when trying to add an element to a page I get the message “The requested URL /content/717/elements” was not found on this server. I am using a fully hosted server with Rackspace - they have checked the settings on the server and there have not been aby changes in the hosting environment

Hi There,

Thanks for writing in!

  1. Ensure everything is up to date according to our version compatibility list at https://theme.co/apex/forum/t/troubleshooting-version-compatibility/195. Please follow the best practices when updating your theme and plugins. See https://theme.co/apex/forum/t/setup-updating-your-themes-and-plugins/62 for more details.

  2. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.

  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

  4. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  5. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

If you still face the issue please send us your website details so that we can have a look.

Please provide following information:
Set it as Secure Note

  • Link to your site
  • WordPress Admin username / password
  • FTP credentials
    All the best!

Hey @marcsr,

Thanks for the credentials. Upon checking, I see right away a potential problem. The X menu and Cornerstone are separate.

This usually is a result of incorrect theme installation. The common mistake is, the X is installed in a sub-directory like wp-content/themes/x/x. It should only be directly installed under themes themes/x.

Please try reinstalling X by:

  1. Switching to the default WordPress theme
  2. Delete X
  3. Install X again but this time, make sure you follow the correct Theme Installation at https://theme.co/apex/forum/t/setup-theme-installation/54

If you already have the correct setup and the issue persists, please give us FTP access also.


Hi There @marcsr

Upon checking, I see that you’re using a custom permalink structure which should be the cause of this issue (see secure note).

Please try selecting a different permalink structure like postname under Settings -> Permalinks area and that should resolve your issue.


Hi There

I have changed the permalink structure as you have suggested - unfortunately it seems to have made the issue worse as I cannot now even preview a page without the error message appearing. I have also tried creating a new page and the error is still the same


Also on checking I now cannot even view a page

Hi @marcsr,

Before we continue, please update your theme first. You have updated your cornerstone but not the theme, it’s causing incompatibility.

And it seems to be a URL rewrite issue and it’s not supported by your hosting environment. Try accessing a non-existing page, instead of displaying Wordpress 404, it will then display the 404 error page built-in to hosting. I recommend contacting your hosting provider to correct or enable URL rewrite for Wordpress. That could be the reason why your permalink has index.php.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Hey @marcsr,

I went to Settings > Permalinks and saw you’re using the Plain option. I switched to Post Name and now the issue was fixed. Clicking on the Elements or Inspector tab does not redirect anymore.

Hope that helps.