Updates not appearing in private browser

Hi there,

Strange one…

My changes to a page are showing for me, but I had reports of changes not appearing for some others.

Assuming it was a caching issue, I checked this in a private browser and it’s showing the previous version.

I tried recreating the page entirely (using templates) and it’s still doing the same thing.

The end goal is to change “Preorder” to “Order now”.

See screenshots.

Hello @archerthefox,

Thanks for writing to us.

It might be the issue of cache, I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing for Plugin Conflict
  2. CSS/JS Customization
  3. Version Compatibility
  4. Disabling Cache

If none of those work, please send your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password
  • Exact Page URL

You can find the Secure Note button at the bottom of your posts


I removed my custom CSS, saved it, and pasted it back in and saved it and it worked.

Hey @archerthefox,

We are really glad that you have resolved the issue already. Thanks for letting us know!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.