Uncaught Error: Call to undefined method TGM_Plugin_Activation::get_tgmpa_url()


I am getting the following error in relation to the X theme:

When seeking help with this issue, you may be asked for some of the following information:

WordPress version 5.4.2

Current theme: X (version 7.2.3)

Current plugin:  (version )

PHP version 7.1.33

Error Details


An error of type E_ERROR was caused in line 239 of the file /home/psiwebor/public_html/wp-content/themes/x/framework/functions/updates/class-x-tgmpa-integration.php. Error message: Uncaught Error: Call to undefined method TGM_Plugin_Activation::get_tgmpa_url() in /home/psiwebor/public_html/wp-content/themes/x/framework/functions/updates/class-x-tgmpa-integration.php:239

Stack trace:

#0 /home/psiwebor/public_html/wp-content/themes/x/framework/functions/admin/markup/page-home-box-extensions.php(33): X_TGMPA_Integration->bulk_manager_url()

#1 /home/psiwebor/public_html/wp-content/themes/x/framework/functions/admin/markup/page-home.php(59): include('/home/psiwebor/...')

#2 /home/psiwebor/public_html/wp-content/themes/x/framework/functions/admin/setup.php(31): include('/home/psiwebor/...')

#3 /home/psiwebor/public_html/wp-includes/class-wp-hook.php(287): x_addons_page_home('')

#4 /home/psiwebor/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters('', Array)

#5 /home/psiwebor/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)

#6 /home/psiwebor/public_html/wp-admin/admin.php(254): do_action('toplevel_page_x...')

#7 {main}


I have upgraded the PHP version on my VPS hosting to PHP7.4, removed and reinstalled X at both the ‘Latest’ and ‘Stablity’ versions, disabled and re-enabled other plugins, and the error persists. The error presents to the user as missing header images, and a non-functional header menu. I have followed the instructions on other threads on this issue but with no success.

Please help?


Hello Chris,

Thanks for writing in!

Could you please update to the latest versions?
Our latest versions are:

  • X theme 7.2.3
  • Cornerstone 4.2.3
  • WordPress core 5.3.2 or higher
  • PHP 7.2 or higher

This latest release contains fixes for several issues so be sure to check out the changelog:

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out: How The Forum Works

Please let us know how it goes.

Please see the Secure Note now appended to this report.

Hi @psiweb,

We checked after the theme and cornerstone have been updated to the latest version and seems the error you mentioned is not showing in WordPress dashboard.
You can troubleshoot with a few of the common issues:

  2. Increasing PHP Memory Limit
  3. Theme Update

If none of these helps, can you please add the following code to your wp-config.php for debug setup.
And please inform us for further support.

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

Please find the video will help you to edit wp-config.php and add the above code:

Hope it helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.