Unable to turn off uppercase for nav

Good Morning,

I’ve just created a fresh WP installation and installed X 6.1.6 (running Cornerstone 3.1.6) using a child theme.

The only other plugin I have installed is the LiteSpeed Cache plugin - caching is disabled (and I cleared it to be sure)

I have also tried clearing the X style cache.

X > Theme Options > Header > Links Text > Uppercase - has no effect - I can’t turn off Uppercase

Interestingly changing the font size works, and under Typography changing Uppercase for Headings also works dynamically.

It feels like this is a bug? I will provide login details in a following private post. Would be grateful if you could take a look.

It seems like I may not be the only person affected as a forum search also yields this case: https://theme.co/apex/forum/t/menu-font-showing-in-uppercase-despite-turned-off-in-options/35158

Thanks very much


Further investigation reveals that even if you turn off Uppercase in Links - Text and Save - when you revisit the option is turned on again.

FYI, adding this fixes the problem - but this should be changeable from theme options:

.x-navbar .x-nav-wrap .x-nav > li > a {
text-transform: none;

Hi There,

Thanks for writing in!
I can see you don’t have a valid license for the site.

Please validate your site and update theme and plugins to the latest version, let us know if that fixes your issue.
Validation Guide: https://theme.co/apex/forum/t/setup-product-validation/55
Update Guide: https://theme.co/apex/forum/t/setup-updating-your-themes-and-plugins/62

Hope this helps!

Hi Basanta,

I have a bunch of licences. This is a new site I’m creating for a client and they haven’t yet purchased the license - we want to be sure they like the look and feel. These issues are preventing me from progessing with the project.

I am running the latest version of WordPress, Theme and plugins - all downloaded and installed this morning.

I now have two cases with simliar issues - option selections not saving in Theme Options.

Please could this be properly investigated.



Hello @markwest,

Thanks for updating the thread and apologies for the confusion.

Although it’s a good practice to validate theme but the problem you are facing has nothing to do with validation. I checked the theme options panel and I can confirm that toggling link text uppercase is not reflecting any changes.

I installed WP server info plugin to see the server configurations and most of the settings looks fine to be baring PHP Max Script Execute Time which is not set to 30s. Please make sure that PHP Max Script Execute Time is 300s. I also tried making the changes in my setup and it’s working fine. At the moment I would suggest you to completely delete Cornerstone and X Theme and then reinstall the same and see how it goes. You Theme Options and content won’t get deleted. Other then that at the moment I am not quite able to figure out why changes are not getting reflected. In case problem is still there, please share FTP login details, I would like to take more closer look at this.


Hi Prasant,

I can happily let you have details for other (theme validated) sites where this is also happening.

I’m happy to try re-uploading the theme & CS, but I don’t think will make any difference - as I said - it is happening on every site I’ve updated.

I will supply you with FTP details in a private message to follow.

I have updated max execution time to 300s as requested - but I think you can see that these requests are completing well within the original 30s - changing to 300s hasn’t fixed it.

Kind Regards


Hi Mark,

Thank you for the credentials, I have spend more time on this than I should, nevertheless I have found the cause of the issue. It was this:

What’s funny about that is I though the extra slash / is causing the issue and it is, when I remove that slash the menu becomes lowercase, but now I can’t make the menu uppercase even if the uppercase option is turn on :thinking: (opposite of the original issue)

Only to realize that entire CSS rule is the one causing it :grin:

Hope that helps,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.