Unable to translate pages with WPML

I just installed the WPML plugin but I am unable to translate pages.
Every time I press the flag and click for a copy of a page the message “Uh, Oh! Failed to Create Page” pops up.

I tried to deactivate all the plugins (but WPML) and did not work
Also upgraded to the latest version of Pro Theme and did not work
Also activated the parent Theme with no luck.

There is currently an issue with WPML that we are nearly finished with. Creating page outside of Cornerstone in the WPML editor will still link pages together. We also offer Pro 5 that will work as expected for now. We are aiming for a release of Monday. Apologies for the issue, let us know if you have any other questions.

Thank you for your quick response.
So it is ok in the meantime to work from here (see screen captures)?

Toni

Hi Toni,

Yes, you can continue with that till the solution come.

Thanks

After the update I get this message when trying to either create a blank or a copy of the original version to work on that.

“uh oh! Failed to create Archive. WPML does not allow this post type.”

Is there any easy workaround for this?

My guess: duplicate in cornerstone and translate that copy, then linking that translation manually.

EDIT: Did not work. The page shows up in Cornerstone and anywhere else :frowning:

EDIT2: No matter the route, I can only create Archve pages from scratch in the original language.

image

Can you let me know what your WPML settings say for this post type cs_layout_archive? Got to WPML>Settings and scroll till you see cs_layout_archive. I’m afraid since you ran Cornerstone before the fixes these post types might not be translatable. They should be translatable by default for new sites. Anything with cs_ should be translatable. If they already are translatable, I might need to see on your live site what’s going on as you shouldn’t get that error if the post types are okay.

Thanks for your patience, we’ll get your build running great. And yes the workaround if this is happening is to use the WPML UI, but you’ll still need to change the post type WPML settings.

Yaay! That did the trick!
Thank you so much for your support and patience @charlie and @tristup , truly appreciated.

EDIT: Damn! I can do translate them but when I hit preview it falls back to the original version. I am going to delete cache and review WPML settings to see if I can solve it.

EDIT 2: OK. I had to add the ?lang= to all links in menus and everything was fine. Seems that cornerstone follow the menus for the preview. All good now. :heart:

You are most welcome.