Unable to save on one page only. The rest of the pages work fine

Several different error messages:

This all started happening when we tried to solve the problem with the website not being fully secure. The Siteground tech said some of the website was still http instead of https. He 'forced the .htaccess file to enforce https. That solved the security problem but the issue started up with not being able to update one of the pages of the website. The rest work fine. The preview error shows two different pages so i suspect that wordpress All Pages list is now pointing to the wrong page for this particular page.

I updated the permalinks to be https.
I deactivated all the plugins and it didnt’ help for that page. All the other pages still seemed to work but Research-reports no longer showed up in the preview panel.
I cleared the cache both at siteground and on the browsers.

If you can’t solve this, I’m still able to save a template of the page.
Should i create a new page of the same info? i need to name it exactly the same so i don’t break any links. will that be a problem once i erase the bad page?


Hello @shellison,

Thanks for writing in! It seems that you have exhausted your PHP memory limit. You must increase it to at least 256MB. To do that, kindly check out this documentation article:

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

this problem is only happening with one page. The other pages of my website work fine. Do you still recommend i increase the memory?

Hi @shellison,

Yes, please increase the PHP memory limit and let see if it will solve your issue.

Hope that helps and let us know how it goes.

Thank you.

I sent a secure note with login info.

I increased the php and it didn’t help. If from Wordpress, i go to Pages, and select the Research-reports page and then edit with Pro, it shows me the page in the preview but any changes i try to make, it says it can’t save. If i go to Pro first and then go to Content and select the research-report page from within the program, it shows me nothing in the preview. Also loading of any pages is extremely SLOW. The other pages work fine but SLOW. I can edit them no problem (except the new version of Pro is difficult to use) and can save no problem. There is a problem with PRo accessing the page. One of the original error messages looked like the preview was going to the wrong url for the page.

Hello @shellison,

I have made some changes to your wp-config.php file. I also have fixed your SSL by installing Really Simple SSL plugin.

Check the secure note below.

It could also be caused by a plugin conflict, amongst other things. Please check out this troubleshooting article here and follow the instructions for the following sections (where appropriate):

  • Testing for Plugin Conflict
  • Disabling Cache
  • Disabling CDN

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.