Hi rene,
I’ve checked your website and while working on this issue, I noticed that these errors were being reported in the server error log:
[04-May-2018 20:06:21 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 87389 bytes) in /is/htdocs/wp1107398_YKT7C5QC01/www/wordpress/wp-includes/wp-db.php on line 1469
[04-May-2018 20:09:37 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 40832 bytes) in /is/htdocs/wp1107398_YKT7C5QC01/www/wordpress/wp-includes/wp-db.php on line 1469
This indicates there is a memory limit issue, however when I tried to add these lines in wp-config.php file:
define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '1024M' );
It doesn’t get improved, so I believe your hosting provider might have certain way to increase the memory limit, could you please reach out to them and report the server error log messages that I mentioned above to them?
Thanks.