Unable to save changes to global CSS

In newest version of Themeco Pro 4 I am unable to save any changes to global css. I get the uh oh message.

I have increased php memory to 512 to no avail…

Hello @wowflak,

Thanks for writing to us

It might be plugin conflict or cache issue. I would suggest you, please make sure your theme and plugin are updated as per our version compatibility page. After updating if it doesn’t work for you I would recommend you to check following troubleshooting guide.

  1. Testing For Plugin Conflict
  2. Child Theme
  3. Css/Js Customization
  4. Disabling Cache
  5. Disabling Cdn
  6. Permalink settings

If none of those work, It would be best if you could copying your live website to your staging area. and send your details in a secure note so that we can investigate your setting without breaking your live site. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


So I fixed for one of my sites, it was some bad css. But now have the issue on a different site and the weird thing is it will not save global css changes on the live production site but it will save the changes on the staging site. The live site does go through Cloudflare but bypassing the proxy did not change anything. I will attach creds for both sites.

Also seems to be issues with the headers and fonts not saving.

Hi @wowflak,

This usually is a server conflict with Pro. As you can see, there is a status 403 error in the console. That is not detailed though so please contact your web host to check the error logs and fix the adjust the server settings according to what the error log says. You can also post the error logs in a Secure Note maybe we could point you to the right direction.

Hope that helps.


I went back to WPEngine and they confirmed that production and staging environments are the same so cannot understand why it saves in staging but not production. I will include the logs and notes from them in secure note. Please see if you can help.

Hello @wowflak,

You have added a broken CSS:

I went ahead and remove the broken CSS comment code. And then I also added a test CSS code:

/* Added by the X Staff */
.element {font-size: 10px;}

I have temporarily deactivated the Autoptimize plugin and have cleared the cache in WP Engine > General Settings. The custom CSS was saved and display on the page.

Kindly check your site now.

Thanks, however that did not resolve the issue.

The staging site has NEVER had a problem saving global css. You made these changes to the staging site. The issue is the live production site which still cannot save the css. I have tried all of the suggestions, no child theme, disable all plugins, etc. and nothing works.

I have even just copied staging over to production with the broken css removed and it still does not save.

Please look at the production side. I will include new login info in secure note.


Hello @wowflak,

Can you please update your WordPress core to 5.6?
After that, test your site again.

Kindly let us know how it goes.

I have done this and still no change. Cannot make any saves to global css.

Hey @wowflak,

I believe this has something to do with Cloudflare. Please tell WPEngine support to temporarily disconnect your site from Cloudflare to test if it’s causing the issue. Share the following screenshot to them.

Your staging site might not be connected to Cloudflare, that’s why it works.

If Cloudflare is the cause, please forward this issue to Cloudflare support.


I have already tried bypassing the Cloudflare cache. Can you please send a larger version of that screenshot? Hard to read. Thanks

Hey @wowflak,

Our builders just now use WordPress Rest API. Your web host setup should support that by default.

Hope that helps.

This seems to be an issue with the Cloudflare WAF and how it interprets the way the save is attempted. When I bypass with my ip it works… This will also be an issue with anyone who uses WPEngine with GES as GES is basically Cloudflare. I have confirmed this issue and am having rules made to accommodate.

Hi @wowflak,

We’re glad that you’re able to find a suitable solution to your issue. If you have any other concerns regarding our theme features, feel free to reach us.

Thank you.

Just to confirm, this will be an issue for anyone using WPEngine and their GES platform plus the new Themeco Pro 4. I will add a note in the secure area of what we did to whitelist.

Hi @wowflak,

Thank you for posting your ideas, we really appreciate it.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.