Hello @janequade,
Thanks for asking.
While importing demo content I see following error message in dev tools:
Failed to load resource: the server responded with a status of 500 (Internal Server Error) https://medreps.biz/wp-admin/admin-ajax.php
Next, I checked the PHP version you are runnig on the server and I can see that you are runnig PHP version 5.6.33. Please make sure that you are running PHP 7 or later on the server as running old version of PHP can have potential issues. You can refer following document for server requirement https://wordpress.org/about/requirements/
You an get in touch with hosting provider to upgrade PHP. Upon upgrading the PHP, try importing demo contents again and let us know how it goes.
Thanks.