Typography Issues

Trying to change the headings font and I am setting it in the typography settings, but it’s not rendering the font, but instead it is rendering my body font. I am in cornerstone I select Element > Headline and it still reflects the body font.

Hi Hailey,

Thanks for writing in! Those typography settings will not be affected to V2 headlines, but it will apply for classic elements.

For V2 elements, you need to apply your typography through the font manager. Please follow the steps below.

1.First you need to enable Font manager from X -> Theme Options -> Typography area.

2.Then when you’re inside Cornerstone editor, click on the settings icon

Under the Fonts tab, you can load your custom font. Make sure to save the changes.

3.Now you can select your font by selecting your V2 headline element.

We also have a detailed guide on font manager here (https://theme.co/apex/forum/t/font-manager/101)

Please make sure to clear all caches when testing your page (https://www.wpbeginner.com/beginners-guide/how-to-clear-your-cache-in-wordpress/).

Hope that helps.

Hey! Thank you for your response. I had previously been using the font manager and the V2 headline element, however that was not render the correct typeface either. I then tried disabling the font manger and going through the typography settings to get it to work, but it still had no effect on the look of the typeface.

Hey Hailey,

Please check for the followiing:

#1. Double check that you have both X and Cornerstone updated to the latest version. Here is a link for a details information on how to do an update:

Please remember to clear all caches when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors or any unexpected display issue on the site.

#2. if the issue persists, try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

In case you are still not able to have the Typography work, please provide us with the admin access to your site in a Secure Note:

It did not work. My wordpress is up to date and so is the php. I deactivated all plugins and still nothing. I can only get the class elements to work. I included a secure note.

Hi Hailey,

I checked your site’s code and the font are still set to Inherit, instead of the font selected in the text format above the screenshot. And I can’t login to your site as the credentials are incorrect.

And please deactivate your site/server cache while you’re working on your site. It’s only recommended once you’re done. Else, your changes will not appear instantly until expired.


Hey Rad,

I’m sorry about that, I updated the secure note to the correct information, but I don’t know how to deactivate my site/server cache.

Hi Hailey,

It appears it’s built-in to your hosting environment

But it’s not due to cache, the font is still set to inherit. And it’s because it’s the Advanced option is still off :slight_smile: . I went ahead and turned it on and please go ahead and change the font to your preference.

The advanced mode is toggled off by default on X theme to simplify the feature.


Thank you so much! That worked perfectly!!

You are most welcome!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.