Typekit fonts not showing up in Customizer

I just installed typekit on X and I don’t see it in the dropdown menu for fonts. I only see System and Google fonts.
Please advise.

EDIT: I have found a workaround where I added css selectors in my kit. But I still can’t edit the spacing in the customizer, and every time I go to the Typography section it resets to whatever default font was chosen.

Hello There,

Thanks for writing in! Please go to X > Launch > Options > Templates > Fonts and set up the typekit. To know more about font manager and how you can set up the typekit, please check this out: https://theme.co/apex/forum/t/features-font-manager/101/1

Hope this helps. Please let us know how it goes.

Thanks for the suggestion, but it didn’t work. When I go back into the customizer I still can’t find typekit, but I can see it within the font manager.

I was able to add some custom CSS though so I can use Bebas Neue for H1:

.site h1, .site .h1 {
font-family: ‘Bebas Neue’;
font-weight: 400;

Not the solution I’m looking for, but it works…

Please give us access to your WP Admin in a secure note so we could check your setup.


Please check secure note below.

Also, I just noticed the typekit font (bebas neue) isnt working on android, as well as my windows laptop

Hi, @Palad,

Font Manager is the default since implemented in X5 and Pro.

Go to X -> Launch -> Templates -> Fonts, on bottom left, above the help ( ? ) you have the “T” button, click on it and you get access do to font sources - Google Font and Typekit. Input your Typekit Kit ID and click on Refresh button to see your fonts.

Now you’re able to add or edit some of the font templates to use on your content.

Once you do that Typekit extension is not needed anymore.

Hope it helps!

1 Like


If you go to X > Launch > Options > Fonts > Add new font -> you’ll can select the Bebas in the field normally.

@rafaelgou @john I have chosen Bebas Neue in Font Manager and I’m still seeing Arvo.
I’m thinking this might be because in Wordpress’ Customizer under Typography, I have set Arvo as the default font for Headings.

  1. How do I disable Typography under Customizer?

  2. Also, I want to use Arvo for h2-h6, how can I do that from the Fonts Manager?

Hi there,

You can’t disable it, and you can leave it there since the new theme options are now under X/Pro > Launch > Options. It’s there in Customizer just for backward compatibility but it will soon retire.

And you have to apply those added fonts in X/Pro > Launch > Options > Typography and not in customizer. But, if’s selective only then it should be done through CSS. Like this,

h2, .h2,
h3, .h3,
h4, .h4,
h5, .h5,
h6, .h6 {
font-family: "arvo",serif;
font-weight: 400;

And of course, always purge/clear your caches for every change you made.


Hi rafaelgou,

Sorry for resurfacing an old thread, but it’s been the most helpful so far.

What if my custom font isn’t a Google Font, nor a font I’ve purchased from Typekit/I don’t have a Typekit account?

I’ve uploaded all my font files via FTP (the old school way). Is there any way to surface these?

Thank you :slight_smile:

Hey @kirribillidesigns,

What you described is a custom font. You can follow this tutorial from an X user. Just note that, there’s currently no integration for custom fonts so they won’t show up under Typography.