Themeco X and Connection Issues (incompatible with WP Multisite?)

Background: I have three Themeco X licenses. Two are for websites that are part of a WordPress Multisite (WPMS), and one is just a standard WP site (i.e. not part of a WPMS). All three websites are hosted on the same server and have been operating for over a year. This is the first time the following problem has occurred.

Problem: The two WPMS websites now have connection issues (note, the standard site does not have connection issues). The error occurred when I attempted to update Cornerstone on one of the WPMS websites. The update failed, and I received the following error message.

Update Failed: X is not validated. Validate X to enable automatic updates.

I went to X Addons > Product Validation and verified an API key was already entered. Then I verified this matched what's listed under my licenses (https://theme.co/apex/licenses). Finally, I copy/pasted the correct code listed under my licenses and clicked Update API Key, but I received the following error message.

Could not establish connection. For assistance, please start by reviewing our article on troubleshooting connection issues.

Notes:

  • I repeated these steps on the second WPMS website. The same errors occurred.

  • I logged into the standard website and updated X and Cornerstone with no issue.

  • I contacted our developer, and he went through each of the points listed under Connection Issues (https://theme.co/apex/forum/t/troubleshooting-validation-connection-issues/201). The error does not appear to be occurring because of settings on our end.

  • Since the standard site has no connection issues, is it possible this issue is due to Themeco X/Pro updates and WPMS compatibility?

Please advise and thank you for your help on this matter.
--

Verbose error message:

Not found.

It seems as though the page you're trying to access does not exist or has been moved.

Please click the back button in your browser and try your action again.

Hello,

Thank you for writing in!

The X is compatible with multisites, so if you could post some logins details in a secure note and we`d be happy to take a look.

P.S: You can search by “secure note” on this article if you don`t know about this: https://theme.co/apex/forum/t/themeco-support-overview/288

Thanks for your reply. Login details are below.

Hi there,

Thank you for providing the login information. You are using version 4.1.1 of the theme which is not compatible with our new API system for the connection to our server in order to auto update theme.

The multisite setting is not related to this issue. Kindly backup your website completely and do the update process manually following the guide below:

After that, you will be able to use the Auto Update functionality and the Connection will be ok.

Thank you.

I updated the theme using the following steps, and am now receiving an error message when prompted to enter my license for each site.

  • I used the Download button on the dashboard page to obtain X, which was 5.1.0

  • I manually updated X via the WordPress Dashboard

Error message:

Uh oh, we couldn't check if this license was valid. Details.

When I click the "Details" link, a blank box with no text appears with a "Go Back" button at the bottom. Please advise.

Hi there,

Thank you for the information. I checked your website with the updated theme and found out the problem is the connection between your hosting service provider and our servers. The problem is that your server blocks CURL to our servers:

Please kindly contact your hosting service provider and follow up the guide below with them:

I know you mentioned that you followed the steps with your developer, but it seems that you need to do this with your hosting service provider and they seem to have the permission to do the proper settings.

Thank you.

I contacted the developer again (fyi, he's also the point person for our server provider). He revisited your troubleshooting article and went through all steps, but the error persists. See below for his email.

I also disabled all plugins just in case that was causing an issue, but the error still occurs. Please advise.

Developer correspondence:

Hi there,

Would you mind providing your FTP login credentials in a secure note as well? I think it's best if we directly debug the connection.

Thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.