The requested URL /x/ was not found on this server - followed previous suggestions

I have read the other posts related to the issue and done what is listed below - and I continue to get the error. I am on Godaddy Managed WordPress hosting, Cornerstone 4.0.4

** steps taken **
Updated the .htaccess with the following code:
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

Set the .htaccess permissions to 644

Set the permalink to post name

What do I do now???

Hello @jvedder,

Thanks for writing in!

As you have already tried out much of solutions, please confirm following and let us know how it goes:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  3. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

I did all of the above steps again and it still is not working. I have put login information in the secure note.

Hello @jvedder,

Are you using the “Post Name” as your Permalink setting? To save you time going back and forth, I would recommend that you go to Settings > Permalink and switch to “Plain”. You can now edit any pages in Cornerstone or visit the X > Theme Options. After making all of the site changes, you may go back to Settings > Permalink and switch to “Post Name” again.

Hope this helps.

Thank you for the work-around. I was able to get the updates that were need done. However, this is not an acceptable permanent solution. I cannot tell the customer they need to change the permalinks each time they want to edit the website. And, we cannot leave the website set to plain - which you did by-the-way. That changes the uls and screws-up SEO, so you should not leave a website like that. This clearly appears to be a bug - what is the permanent solution?

Hello @jvedder,

Thanks for updating the thread.

I do agree that every time changing the permalinks is not a desirable solution. Can you please share the administrator login details and FTP login details in secure note so we can take a closer look?

I tried to login using the credentials shared but it’s not a administrator level access.


I have set the role for the provided credentials back to Administrator. Please use the previously provided credentials. I really need to get this problem resolved, the client want to make changes to the website.

Hi @jvedder,

I can see the issue still. At this point please also share FTP credentials too inside a secure note. We need to check the actual htaccess and also check the error log.

I have provided the ftp credentials in a secure note.

Hey @jvedder,

I have accessed your ftp and I resolved the issue. You can now go to X > Theme Options page or edit the pages in Cornerstone without encountering the issue. What have happened? It is because of the x.htaccess file added in the root directory.

Please check your site now.

Thank you! I will now know to look for this in the future.

You are most welcome. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.