Suddenly I have a dark overlay over featured images on my home page

Hi guys,

I suddenly have a dark overlay over featured images on the home page of my site Strange enough I don’t see them on the English version of the site ( Have you any idea?

Best regards,

Ton in 't Vld

Hi Ton in 't Vld,

Were you able to get this sorted? I tried checking the site you have linked but I am not seeing the dark overlay. Kindly try to clear your site and browser cache.


Thank you

Hi Jade,

This is what I see:

Best regards,

Hello Ton,

I am another staff checking in. I do not see any overlay in your post slider. I am seeing the same as the screenshot of @Jade.

By the way, I noticed that you are using an older version of the X theme (6.4.6) and Cornerstone (2.1.7). Could you please update to the latest versions? Our latest versions are:
- X theme 6.5.4
- Cornerstone 3.5.3

This latest release contains fixes for several issues so be sure to check out the changelog (

_After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP Fastest Cache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.-

Please let us know how it goes.

Very strange. In Safari and Firefox I don’t see the overlays.
In Chrome only when I’m logged in.

Anway. Thanks for looking at the problem.

I will update the theme and Cornerstone.


Hi guys,

After updating WordPress the overlay is everywhere now!


Hello Ton,

I have checked and I am seeing the dark overlay in the post slider.

Please try adding this code in X > Theme Options > CSS:

.x-post-slider-entry > a {
    background-color: transparent;

Also, if you are updating X and Cornerstone, please make sure that you update both to the latest version. Here is a link for a details information on how to do an update:

Please remember to clear all caches when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors or any unexpected display issue on the site.

Hi Jade,

That css was already there. So it didn’t solve the problem.

Apart from this problem, I also have two other problems:

  1. Cornerstone says there is an update, but I already updated the theme, and tried to update Cornerstond seperately.
  2. I cannot validate my license. I tried several times. I even activated another them, uploaded the newest version of X. And as you can see, I have a license for this site.


Hello Ton,

It could be that there is a CSS error in the code that you have in the Global CSS that is why the code is not taking effect. To verify that, please copy all the codes that are in the Global CSS and paste it here.

It should provide some information if there are any CSS error that is causing the issue that you have to fix so that the CSS codes will work.

It seems that you are using an older version of X which is not compatible to the current validation process. Because you of that, you will have to update X and Cornerstone manually then validate the site. To do that, please follow the suggestion here under the heading Manual Updates.

If you are still not able to get things sorted, please provide us with the admin access to your site in a Secure Note:

I’ll give you log in info.

Please first update Cornerstone either by Manual Updates as Jade suggested. Or, uninstall or deactivate and delete Cornerstone and go to X > Validation and X will install the compatible version automatically.

We’ll investigate after that.


That worked!

Many thanks guys.


You’re welcome, Ton. Glad we’re able to help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.