Stop section from scrolling behind navbar


On my homepage I have a section (“A”) with an anchor link to the section below (“B”). I would like the top of B to be fully visible and not to be hidden behind te navbar. I’ve tried several CSS solutions (like scroll-padding-top and some other work arounds). I also tried some JS solutions offered in this forum. However, nothing seems to work.

What am I missing? It can’t be that hard…

Thank you!


Hello Hugo,

Thank for posting in! To get your issue resolved, please make sure to set the minimum height of your navbar in Cornerstone > Theme Options > Headers > Navbar > Top Height with the actual height of your navbar. Setting is smaller than the height will cause the issue. If this is not helping, please provide us with the URL of your site in a secure note. You can create a secure note in your next reply with the following info:
– Link to your site

If we need to log in to view the URL:
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Hi Rue,

Thank you for your quick reply. Yes, the set height in the settings and the actual height are the same.

Thank you in advance for looking into it!

Hi Hugo,

I have checked and found that you set the Top Height value to 90px which you need to adjust as per your need. While using the Sticky Menu in the One Page navigation you need to adjust the height to calculate the offset. I would suggest you increase the Top Height value and check if that works for you.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.