Sticky scroll

Help please.

When scolling down my site, the screen automatically stops at some points (like where the header stops) - is this a setting I can change??? I have looked up and down through the settings but cannot seem to see where in the settings I can change this.

Many thanks

Hi @Mick,

To make the navbar sticky on small screen sizes, please add the following CSS under Theme Options > CSS:

@media (max-width: 979px){
    .x-navbar.x-navbar-fixed-top {
        position: fixed;

Hope it helps :slight_smile:

Hi - I dont think I explained myself very well. I dont have an offical header or a navbar. Please see the website below

when you scroll from the top, the scroll ‘gets stuck’ at the first hero image.


Hello Mick Shah,

I have check the url and it seems that there are two scrollbars. Did you add any custom css? To resolve this, please add the following CSS code in the X > Theme Options > Global CSS (

body {
    overflow-y: hidden;

We would love to know if this has worked for you. Thank you.

Hi - No sorry - this hasnt worked. We had our site developed by a graphic design studio and there is lots of CSS code so not sure if there is something in there? Can you suggest anything else?

Hello Mick Shah,

Hello There,

Would you mind providing us the URL of your site with login credentials, if necessary, so we can take a closer look at your css and other settings? This is to ensure that we can provide you with a tailored answer to your situation. Once you have provided us with your URL, we will be happy to assist you with everything.

To do this, you can make a post with the following info:
– Link to your site
– WordPress Admin username / password

Thank you in advance.

I have just sent you a private message with login details - please can you confirm you have received it.

Hi Mick,

Thanks, but please do not direct message us because we do not know who is going to handle the ticket next (we have different shifts). Please provide us your login credentials in a secure note instead.


Hi Mick,

Thank you for the credentials, but that account has limited access.

Anyways, it seems the CSS code provided by Ruenel above solved the issue? Can you confirm that on your end?


Yes - thank you. All works fine now.

You are most welcome. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.