Soft 404 - Google Index

Hey there,

I have a problem with Custom 404 plugin and Google.
I read this threat about you guys, and you told that there’s a pending task a year ago:

Is that fixed? Or what I have to do to fix the problem?

Thanks and have a great day

Hey Dario,

I tested our Custom 404 extension and it’s outputting the correct response header (404). Are you using the latest version of the extension and X, Cornerstone and Pro? You can check the latest versions in our Version Compatibility list at

If that is the case and the issue persists on your end, would you mind providing your site’s WordPress Login URL, Username and Password so we could see your setup and replicate it on our end? You can post sensitive details in a Secure Note.


Hey there,

the site I’m working on is, the page is
In the plug-in update page there isn’t the custom 404 plug-in, so I guess it’s the latest version.

Please be carefull with changes that this is a big company, that manages tracking and stuff…

Hi Dario,

Could you try editing this file wp-content\plugins\tco-custom-404\views\site\custom-404.php through your hosting file manager or FTP with your preferred editing software. Then replace this line

$wp_query->is_404 = false;

with this

$wp_query->is_404 = true;

It all works just fine on my end without this change, perhaps it’s just isolated to your setup. And please note that this page will not return 404 in any way since it’s an actual page, it’s only used to display the content for the actual 404 view.


Hey, thanks for the reply.

So, the only way to avoid a google index error, is to turn off the plugin ‘custom 404’ since it gives just one option: to replace the 404 page with another one. Is this true?


Hi Dario,

Yes, that is only used to replaced or display for the pages that results to 404, like’t-exist-but-will-still-display-the-custom-404

But no, you don’t need to deactivate it. If your issue is due to google accessing the page then you’ll have to exclude it by using robots.txt That’s because google will still access since it’s a standard page like any other page (HTTP 200), unless you block it.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.