Slider Revolution loading Java and CSS on all pages

I want to only load Slider Revolution Java and CSS on pages that have a slider. The site loads slow due to the fact I have many sliders but not on every page. When I turn on the option to only load on the pages via the Slider Rev dashboard, the slides all disappear on the pages. Is there a way to make this work with themeco pro?


Hey @wowflak,

In Slider Revolution > Global Settings, there are performance related settings.

You can enable them one by one and check it it’ll affect the front-end loading of your sliders.

Here are additional resources you can check out from ThemePunch:

Hope that helps.

Hi, I have done all that. What I want is to limit where the scripts load. They currently load globally. If I turn that off so that it only loads on pages where slide is present the slide disappears.

Specifically it disappears only on “Pages” made with Pro and Slider selected as below masthead. See here:

However on this page where the slider is just placed it works:

So it would be great to fix it so that the pages with the slider selected below masthead worked as I havemany that way.

Hello @wowflak,

Thanks for updating the thread.

I activated the Revolution Slider performance settings and then created a page using Pro Theme content builder. After that I assigned Revolution Slider to the page in above and below masthead, however in my local setup slider is working fine. I that regards, please try out following solution:

  1. I see that you are using WP Rocket cache plugin. Please try clearing cache.
  2. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  3. Make sure you are using the supported version of Revolution Slider plugin. As of today the supported version of Revolution Slider is 5.4.8.
  4. Please make sure you are including the correct page id to include Revolution Slider libraries. To lean more about finding page id, please take a look at following article.

Let us know how it goes.


So it worked with the Include libraries globally set to OFF?

Because if I set the global libraries to OFF in Rev Slider the slider will not work below masthead. I also tried creating new page and clearing all cache and still no luck. For whatever reason if it is off globally, the libraries will not load when it is using the masthead option.

Hi @wowflak

I’ve tested this scenario in my localhost and I encountered the same issue, that’s why I’ve reported this one to our dev team for further investigation, at the moment I don’t know whether this is going to be fixed or not and when it will get fixed, our dev team is working hard to set the priorities to fix bugs and introduce new features according to the roadmap.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.