Slider Revolution does not response

We have upgraded the slider revolution. Sliders on the mobile version is not responsive anymore. We tried to change some of the settings but the plugin gives “Ajax Error!!! error” and nothing can be adjustable anymore. You can see the error message we get below;

Hi Jamie,

Thank you for writing in, please do the following;

  • Ensure that you are fully up to date. WordPress, Theme, and Envira Gallery (Version Compatibility)

  • Clear all the site caches (plugin, server-side, CDN, and browser’s cache) so that the code from the latest release is always in use. This will help you to avoid any potential errors. Please deactivate this caching features while we tackle this issue.

  • Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

If nothing works please provide us login credentials in a secure note so we can take a closer look.


Hello Friech,

  • Our WordPress and Envira Gallery are up to date.

  • We clearned all the caches,

  • I deactivated all the plugins and try changes something on slider revolution. It is not still changable, it gives the ajax error all the time.

Ill provide you the login details, thank you.

Hey Jamie,

I checked your sliders and I didn’t see an Ajax Error message. The first few sliders are working on my end too.

Since you have lots of sliders, would you mind telling us what sliders are having the issue?


Hey Christian,

We are having problem with slider called “Home Slider”. It is possible to fix it today. since we have launch our newsletter and the title on the slider on mobile is not proper.

Thank you.

Hey Jamie,

Thanks for getting back with the specific slider. I now see the issue. Regretfully though, there’s not much information generated in the console. There is just a 404 error when calling admin-ajax.php of WordPress which is used by Slider Revolution.

There are numerous factors that could cause that error and the only thing that could tell us what the exact cause is is the server’s error log. With that said, please give us cPanel or FTP access too so we could read the error log and see if the issue is coming from Slider Revolution or a third-party factor. In case you don’t know what cPanel or FTP is, please ask those from your web host.


Hey Christian,

the FTP acces is provided in the Secure Note.

Thank you

Hello Jamie,

Could you please update to the latest versions?
Our latest versions are:

  • X theme 7.0.4
  • Cornerstone 4.0.4

This latest release contains fixes for several issues so be sure to check out the changelog (

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

We also recommend that you update your PHP version to at least 7.2 because WordPress 5.2 requires at least 7.2 ( This could possibly be the cause of the issue. In most cases you cannot update your PHP version yourself and need to contact your host about this. The upgrade process is an easy process and should be something your host can do for you without affecting your website or charging you for it. Here’s a letter you can send to your hosting company:

`Dear host,

I’m interested in running the open-source WordPress web software and
I was wondering if my account supported the following:

  • PHP 7.2 or greater
  • MySQL 5.6 or greater
  • The mod_rewrite Apache module
  • HTTPS support

Looking forward to your reply.`

Hope this helps. Kindly let us know.

Hello RueNel,

We created the homepage slider from scratch, not it works properly. However, we have two problems now.

  1. Even though we set poster image to every single slider, it doesn’t show the picture when we go to the website on incognito mode. How to fix it?

  2. The videos load super slow,we set smart lazy loading but it seems like it is the same as before. How can we improve the speed of the sliders?

Thank you.

Hi Jamie,

1.) It is showing for me, though just not right away. Look, I can see the transition from background image to video:
Please try to disable loading instead and then check our suggestion on #2

2.) I ran a speedtest and result is really bad. We have put together an article regarding performance and you can use it as a foundation to tune up load time as website is taking considerable amount of time to load all the resources (

Hope this helps.

Hey Lely,

  1. We did remove the spinning feature.However the cover image does not show immediately.

  2. We did most of the things that you have mention on the customizations performance except CDN. Is there more we can do more on that. Also does the lazy loading button really works because it looks like nothing has changed whenever I change Smart to Single or All.

Thank you.

Hello Jamie,

The cover image will only display within the slide. I would recommend that you add a background image in your global layers so that as soon as the slider is loaded the global layer will display first then the cover image and the video once it is loaded.

Hope this helps.

Hey RueNei,

We have already tried to put background picture to our slider but we managed to put only one background picture not a specific background picture for each pictures. So the background picture we set began to pop up out of the blue and not related to the second slider. Previously before the update we did not had problem with the cover pictuure and now we cannot solve the problem. Is there anything else that we can do it?


Hi Jamie,

Please try disabling the lazyload option too. That’s what I meant on my previous reply on #1. Choose No Lazy Loading from the options:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.