Slider Revolution background video not displaying full size

My Revslider background video is no longer showing the full width of the page, it used to but for some reason it is no longer wide enough to fill the screen. My settings:

Layout: Sizing: Full width
Background: Video Fit Cover => ON
Source TypeEntry-fullwidth (I tried them ALL)

In the preview it displays correctly but not in live view,. the video is clipped. What changed and how do I fix this?

Hello Mark,

Thanks for writing to us.

I checked your site it seems that the slider video is fullwidth and working fine. Please have a look at the screenshot in the secure note. It might be an issue with the browser cache. I would suggest you clear your browser cache and then check it again or check it in the private mode of the browser.


I did check in incognito mode and also with different browsers, Edge/Chrome, cleared all caches, they still all clip the right side of the video and are not showing it as full width

Hello Mark,

I checked in Google Chrome version 92.0.4515.159 and Mozilla Firefox 90.0.2 version and it is working fine at my end. Can you please let us know which version of the browser you are using?


Google Chrome is up to date
Version 92.0.4515.159 (Official Build) (64-bit)

Microsoft Edge
Version 92.0.902.78 (Official build) (64-bit)

Hello Mark,

Please edit your slider and make sure that in your slider layout settings, the wrapper maximum height is NOT set to 500 pixels.

If this is not helping, we would love to check your slider settings if you wouldn’t mind that we access the site. You can create a secure note in your next reply with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Hello Mark,

Thank you for the credentials, I’m able to replicate the issue on my end. It seems like the W3 Total Caching is causing the issue.

When this plugin cache and deactivated the slider work just fine.

Always remember to clear all caching after an update is done on the site.


I always do clear the cache after updating plugins/themes. Are you saying that Slider Revolution will not work properly as long as the very popular W3 Total Caching plugin is active?

Hi Mark,

What my colleague is trying to say is that there could be a configuration in the W3 Total Caching plugin that makes the slider revolution not to work or still hold a cache file for the revolution slider. It could be best if you properly clear your cache.

Hope that helps.

Thank you.

Obviously clearing the cache doesn’t help. So the Slider Revolution is incompatible with W3 Total Cache, and you can’t resolve this because you don’t support either one?

Hello Mark,

The Slider Revolution or any plugin is always compatible with the W3 Total Cache. They work independently. You just have to make sure that every once in a while, you clear the W3 Total Cache plugin’s cache so that the latest changes in your site, theme options, or even in plugin settings, will be loaded by the W3 Total Cache. If clearing of the plugin cache is not done, the old cache version of the site will be loaded.

Anyways, I have temporarily deactivated the W3 Total Cache plugin. I also edited your slider by switching the layout sizing from Auto to “Fullwidth”. The height of the slider was changed to 1200 pixels too.

The slider is now displaying much bigger. I will leave the W3 Total Cache deactivated while we are still testing. You can also change the layout zing to Fullscreen and test the site again.

Be advised that the head of the lady will always be cut off because that is what is in the video.

Best Regards.

I don’t want the video height to be scrollable, before it fit full width horizontally with no scrolling, so it shouldn’t have changed from that since I didn’t make any changes (other than update XPro). W3 was not the cause either. How do we get it back to that - full screen WIDTH but not so high that it has to be scrolled? What would make this change from the original fit?

Hello Mark,

You will need to change back the Layer Area size to at least 500 pixels which is your previous settings.

Please be advised that the video background will have to resize according to the video ratio settings in your slider. I have inspected your video and it is 1280x720p resolution. In your Layer Area size, it should be changed to a width of 1280px with the height of 720px because the video aspect ratio is 16:9 and set to Video Fit Cover. This means that the video will have to cover the fullscreen while covering the area. The video maybe zooms in or out depending on how wide the screen width is. On most screens, the background video will display nicely using the above settings.

Hope this helps:

This is still no good. No matter what I try it always cuts off the letters to the left and there is a blank space on the right f the video. For whatever reason it can not center. Is there a way to adjust this with css, perhaps float right so it loads either to the right of the frame or at least in the center where it should be?

Hi Mark,

It seems the height of the navbar is also a variable of the issue because when I set the Navbar Top Height (in Theme Options) to at least 71px the slider gets fixed. I just can’t find where is that extra 15px coming from, the navbar height should be fine at 56px, but I can’t point why it needs to be 71px, probably a UberMenu configuration.

The cache is still involved in this so make sure you clear the cache when you do changes on your site.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.