The PHP needed updating - I could not figure out how to delete this post! problem is solved!
I updated several plug-ins, and the X theme for my client, The Slider Revolution plug in threw an error and resulted in a -white screen with a warning that I exceeded size and something about google fonts - the site was working fine before the update and has been for the past 9 months. I deactivated the plug in to restore the site.
Also, When I go to pages>front page, I see the cornerstone logo and a menu shows up on the left listing all the site pages, although I am unable to edit any pages in cornerstone.
I am on PHP version 5.4.45 - this could be the problem? I am not sure how to update my php ?
I was about to revert through Go Daddy but figured I would wait to hear from support first since we will need to address these issues to be current with updates.
Please advise and thank you!
Simone