Slider Broken on One Page, Not on Other


I have a slider of partner logos saved as a component. It displays just fine on one page, but on our homepage, it’s just blank! This started very recently. No idea what’s going on.

Things I’ve tried:
Clearing site cache
Turning off image optimization plugins
Deleting the component element on the page, saving, then adding a new component element to the page
Duplicating the component and putting the new one on the page

No idea what to do.

Page that works:
Page that doesn’t work:

Admin login in secure notes

Hello @aleminopuy,

Thanks for writing to us.

I tried to access your site dashboard but the given credentials are not working on my end. Please recheck and send us again. I also noticed that there is some console error, it might be the issue of plugin conflict or custom JS code error. I would suggest you troubleshoot a few of the common issues before we investigate your settings

If it doesn’t work for you please share the correct login credentials so we can check it on our end.


I had the username incorrect. I edited the note. It should work now.

And if it was a plug-in issue, why is it working on one page and not another? Also, nothing has been changed between it working and it not working.

Hi @aleminopuy,

I have checked both the pages and found the slider is working. If that is not the case and you are trying to point out something else, please provide any screenshot marked with the issue or any video that helps us to recognize the problem.


It sure is!

I saw it was back this morning and came here to see what you did to it - I guess the answer is nothing!

Well, thanks for being willing to take a look.

Have a great day.

STATUS: Resolved
CAUSE: Unknown

Hi @aleminopuy,

I assumed cache might be the reason behind your problem.

Reopening this - it’s not working again.

I’ve cleared the cache on the server, and on my machine.

It’s not displaying on

But it does display on

It’s the same component on each page. And what’s strange, is if you’re on the front page where it doesn’t work, if you click and drag from inside the blank slider, you’ll start pulling out an image (like when you click and drag on any image when, say, dragging it to your desktop or something). So the images are there, but they’re not displaying right. (Hope that makes sense).

And if it works when you visit, try from an incognito window because when I visit, I see it work most of the time, but that’s an older cached version from my local machine.

I just can’t understand it because it displays on one page, but not the other, and it’s the exact same global component (or whatever they’re called now).


Hi @aleminopuy,

I have checked it again and found that the slider is working fine if you are logged in. It seems that the issue is related to the Server Level Cache, I would suggest you contact your hosting provider to purge all the server-level cache and check if that helps or not.


As all my visitors are not logged in, this is a problem. Will the server cache thing work for that? And this has never been an issue in the past (and isn’t on that other page). I’m so confused.


I host on Siteground and am using their Speed Optimizer plugin. When I unchecked ‘minify javascript’ it all worked again.

STATUS: SOLVED (for real this time!)

Hey There,

It’s good to know that the issue has been resolved. We appreciate for letting us know.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.