Site performance

Hey,

unfortunately I still have problems with site performance as mentioned in this ticket: https://theme.co/apex/forum/t/page-performance-site-not-loading/30762?u=zirgon

Renaming .htaccess relates to a 404. I have no clue how to fix the problem. I’ve updated the secret message section with all login credentials, could you please have a look at it?

Best regards
Alessandro

Hi @zirgon,

It’s more likely host environment related. Are you on shared hosting? Some host has limited connections that if you reached it then it will start throttling the connections. Hence, reason why it will work for sometimes, and the builder uses many connections depending on how many content and requests.

It’s maybe related to NGINX and internal caching as I see that often. I checked your site details and it does run on NGINX server.

Could you try it on another host? I’m able to reproduce the issue, after typing few words is stopped working (the preview doesn’t display the changes as the requests are blocked) so I assume it’s host restrictions.

Thanks!

The thing is, I have tried out 3 hosts now, all with the same issue! Anyway, its not possible to change the host in every case… I really need some details what kind of values are needed for X. The Betheme Theme for example has a feature which is checking all values to have the right settings.

One host is completely managed by myself, so I could make changes on every detail of the the setup. But I really have to know what to change, so I could try it out and give it to my hoster for the the other two cases.

Hi @zirgon

Would you mind providing more details about the 3 hosts? Maybe we could use the information to compare what’s common on them. There are no particular values, but the builder is greatly affected by cache and NGINX setup (not always).

I’ll continue checking but I can’t promise any solution.

Thanks!

At the moment, all 3 hosts are providing plesk, so I’m really free in changing details. I tried to change the setting below, but if try one of the other options than “FastGCI operated by Apache” the site becomes unavailable…

Hi There,

Upon further testing, I see the following error on the console log when builder is failing.

Xfr request made by preview timed out

Usually this should be resolved after increasing memory limit as you can see here (https://theme.co/apex/forum/t/another-a-conflict-on-the-front-end-of-your-site-has-prevented-the-preview-from-loading/12754/4?u=mldarshana).

With regard to the error that you’re getting when changing to Apache, you will need to contact your hosting provider to get more information.

Thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.