Site icon/Favicon not working

I’ve uploaded a ‘site icon’ under Appearance>Site Identity>Site Icon, but the favicon still does not show up when visiting the website. However, it does show up when I’m inside the Wordpress or Theme X backend.

How do I fix this?

Hi There @cfckiley

Thanks for writing in! Upon checking, I see that you’re using an older version of X theme (6.0.4) and Cornerstone plugin (3.0.4) on your site. The latest version of X theme is (6.3.8) and Cornerstone plugin (3.3.8) as you can see on our version information here ( Please update your X theme and any outdated plugins by following our guide here (

Also check your WordPress version and make sure to update to the latest version, if you’re using an older version (

Once you’re fully updated, purge your server cache (if you’re using a caching plugin on your site) and clear your browser cache as well before testing.

If you’re still having issues, provide us with your WordPress login credentials in a secure note to check your issue further.


I’ve added a secure note with the website that is having the favicon problems

Hey @cfckiley,

I’ve tested your favicon in my dummy site (deleted it after the test) and it works. This means that there’s some third party plugin or server and/or WordPress configuration that is causing this issue.

I see that you’re using a caching plugin. Did you clear all caches as Darshana suggested previously? If so, please do purge all caches again and also ask your web host if they do have server side caching. Please ask them to purge all caches on their side also.

Please also note that this is not an issue with the theme because there’s nothing in it that could prevent a favicon from displaying as you can see in my screenshot. Sorry if this was not made clear early on.

If clearing all caches doesn’t work, the next thing you could do is to test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

If it still doesn’t help, regretfully, you will need to forward this to a third party WordPress developer to take a look at your configuration.


Thank you. It was the Facebook Comments (by Themeco) plugin that was causing a conflict. I deactivated it and the site icon worked again.
This isn’t ideal though as we would like to keep Facebook Comments on our blog.

Hi There,

I cant replicate that conflict on my end, Please ensure that your Facebook Comments extension is up to date (Version Compatibility) to avoid incompatibility issue.

Updating Your Themes and Plugins

Remember to clear all your caching features (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.