Selecting an element to edit using Cornerstone not working

I have updated to the latest Wordpress and X Theme and since that when trying to edit my Cornerstone pages, selecting elements to edit is not working…

Can you help please…


Hello @RoyPurlan,

Thanks for writing in! I have checked your licenses looking for the URL. You seem to have several URLs in there. Could you please update to the latest versions? Our latest versions are:

  • X theme 8.0.10
  • Cornerstone 5.0.10
  • WordPress 5.6
  • PHP 7.4

This latest release contains fixes for several issues so be sure to check out the changelog:

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Please let us know how it goes.

Hi, hope you got my secure reply…

Hey @RoyPurlan,

I tested what you described but Cornerstone works fine on my end. Would you mind testing again in a different browser? If it works, that means there’s a browser addon causing the issue. You should check or disable your browser addons to test.

If the problem is only happening on specific pages, please provide the URL.


Hi, Thanks for your reply…

I am using Chrome Browser on a new iMac and have never had any issues.

I turned off all plugins and still had the same problem… elements when clicked not opening up in the edit panel to edit…

I tried editing in the Safari Browser but have the same issues…

I then tried one of my other sites which had not been updated so it was using
WP version 5.5.3
PHP version 7.3
X version 7.2.3

All worked perfectly and instantly with edit panels opening on instant clicks… until I updated everything to the same as the site we are trying to fix.

I now have the same issue on two sites. I go into Cornerstone to edit the page, select an element on the page and click it, the edit panel does not open for editing on that element… it seems to be frozen…

Something has changed in the update for this to happen.

I have at least a dozen x themes which I am constantly working on for my clients so would need a fix urgently…

Are there any setting in Cornerstone that are giving me this problem, now on two sites…?

Kind Regards


Hey Roy,

I loaded your site on Big Sur Mac using Chrome 87 and I still could edit elements.

I understand this is critical for you but it’s best practice for website owners to test updates in a staging copy of a website. With that said, I’d recommend that you revert your site from a state that the builder still works. Ask your web host if they have a backup of your site in case you’re not familiar with this.

I’d love to help but I can do nothing if I could not replicate the issue on my end.

Please also try other computers. If it would work on others, this means that this issue is an isolated case. Please try updating and/or reinstalling your Operating System and browsers to see if it will work.


1 Like


I have tried the edits on my old MacBook Pro and things seem to be working as they should although it loads slower…

I do however want to use my new iMac see details below

and things do not work as they should.

When I click an element, loading seems to be slow. It would initially open the edit panel loading slowly, then it would freezes…

This problem is very new to me and I cannot see that I have done anything wrong? I would expect that following your instructions to always keep up to date with versions is the correct thing to do…

I would like you to help me to solve this issue and give me some advice as I have several sites that need updating, and would also like to work using my iMac which I have done previously before the updates. The iMac surely cannot be the problem…

Kind Regards


I have been having another go to see what is happening and find that once I click an element to edit, loading is slow… but it does open the edit panel after a while.

If I click elements that are just Text, it is slow but quicker than elements that are bigger like Feature Boxes… which take an age to open, if not frozen…

Will this help in trying to find the cause…?

Kind Regards

Hi @RoyPurlan,

As my colleague said, we’d love to help you fix the issue with your website but still, we can’t replicate the issue on our end. I also check the console log if there’s any script that interacts with the errors but I don’t see anything. I created a short video showing that the element is editable on end.

So this is only happening on your end. I suggest that you clear your browser cache.

Thank you.

I’m having the same problem.

When I select an element in the site preview, it does not automatically navigate to that element’s properties.

I’m using:
Chrome Version 87.0.4280.141 (Official Build) (64-bit)
X Version 8.0.11
Cornerstone Version 5.0.11

When I try in Chrome or Chrome incognito, I have the same exact problem. When I select an element in the site preview, it does not automatically navigate to that element’s properties.

However, when I try this in a different browser like Firefox, it works.

Any suggestions?


I should also mention that I’m having the same issue in Edge as well.

I have completely erased all data in Edge and tested but it still does not work.

Hello @aaron_softwarepromotions,

I have compared both in Chrome and Firefox. It is easier in Firefox since it is a bit more responsive. There seem to be some weird results when in Chrome. Sometimes it freezes. Our developers are already aware of this. They are investigating this further.

Please bear with us.

Okay, I currently have X Version 8.0.11 set up on a staging server so please let me know once I should test again.

Hi @aaron_softwarepromotions,

As my colleague stated that the developers are aware of this issue and they are investigating it. Although it will be fixed for sure, regretfully there is no ETA for that currently.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.