Scrolling getting stuck on iPhone only

It seems on iPhones the scrolling gets stuck on the website. Android devices scroll without any issue. I read some previous posts and there could be an issue with some of the settings.

Hello @Fair,

Thanks for writing to us.

I tried to access your site but the given site is not accessible at my end. Please disable the security plugin and so that we can check it



The firewall has been disabled.

Hello Jonathan,

I am still seeing the Sucuri Firewall.


Do you use a set block of IPs I can whitelist because I have the option turned off.

Hi Jonathan,

It is advisable to completely disable the firewall restriction so that any of the team can access your website. Once, we are done with the troubleshooting, you can turn it on again.

Thank you.

I disabled the firewall.

Hello Jonathan,

I tried to access your site but I am not able to access it. I would request you please recheck and let us know when it is accessible for us. Please have a look at the given screenshot in the secure note.


I figured out the problem, it was blocking specific countries from view\post. You should be able to access the site now. Sorry for the back and forth.

Hello Jonathan,

It seems that you have set the Header Bar fixed height that might be the reason for the scrolling issue, I would suggest you go to the Header builder and set the Header bar height as auto. In case if it doesn’t work for you we need to check your settings so I would request you please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


I changed both bars height to auto but we are still having the issue. I have added a secure note to log in. Thank you.

Hey Jonathan,

I have replicated the issue and this has something to do with what seems to be a bug with the Modal and Dropdown elements.

For now, please set your Footer Bars’ Height to auto and set the Bar Overflow to Hidden.


Then, add the following code TEMPORARILY in Theme Options > CSS

.x-root {
    overflow: hidden;

IMPORTANT: Please test removing the code in the next theme update. If the issue is resolved, you can delete the code.


That worked, thank you!

Always welcome.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.