Revolution slider white space under slider


There’s probably an really ease solution to this, but I cant seem to solve it.

I want to make a slider at the top of all my pages. Just a simple one image slider wth a layer of text on it. Image has to be full-width.

Reason why I am forced to use the slider, is that it seems that in cornerstone I cant use the Image option or section background option. If I use the image option, I cannot add a layer with text. If I use the section background, I can add a test layer, but the image becomes flexible and will not be shown entirely on different devices.

So I made a slider with one image and a layer of text. When i publish the slider on the page, I will get a white area directly beneath the slider. First I thought it was due to margins, but all is at 0.
Then I noticed that the white area is the unused area of my Grid layer in Revolution. I can only shorten the vertical size of the grid and then the white area gets smaller. But that doesnt solve the problem because the grid layer is the maximum size that can be used by the slider. In my opinion it shouldnt be showing the empty grid space at all. But I can find any solution to not show the unused grid space.

Could you help me out?

Hey Auke,

Is there a chance that you can provide the link to the site in question so that we can check it? I tried to check your account but you have several licenses registered so I am not sure which site you are working on.

Thank you.

yes sure.

I put a password on it: xsupport

at the top you see the slider and then a big white space

Hi Auke,

Instead of using the revslider element, please utilize the theme Slider Below Masthead Feature

Then make sure that you have selected full screen for your slider layout

and that, you have added .masthead as offset

Hope that helps

Hi Paul,

I did that.
Its still the same, with the difference that the white area seems a little smaller and now the next section after the slider (white area) has a small green line just before that section starts

Hey Auke,

I tried checking the page now but it goes to a 404 page. Have you deleted the page?

We would like to see the current state of the page so that we could check it.

Thank you.

the password was removed. apologies.
I put the page open, so you can now access it without password

Hey Auke,

Thanks! I could see the page now. Please try setting the height of the slider in the Slide Layout settings:

Hope this helps.

that doesnt work
I set the grid size height to 1px now
and its still the full image wth the same white space underneath

Hey Auke,

In that case, please provide us with the admin access to your site in a Secure Note:

I sent u secure note with credentials

Hey Auke,

Please also set the Slide Layout to Auto or Fullwidth instead of Fullscreen.

Then set the slider height to around 523px.

Hope this helps.

Hi Jade,

I set it to 523 px and tried both auto and fullwidth.

There is still a green line just before the next section.
The white space is now gone, but has re-appeared above the image.

When I look in my Revslider editing I see that the image has now been moved (by you or colleague) from the top of the grid to the bottom.
So now we are seeing the top part of the grid (the unused part) as a white area.
Isnt it unlogical that a slider is showing unused parts of the grid-area as a white block?

Hello @rainmakernl,

Thanks for updating the thread.

To remove the border, you can add following CSS under X > Theme Options > CSS:

.x-slider-container.below {
    border: none;

Regarding the white space area I would suggest you to first update X Theme , Cornerstone and Revolution Slider plugin. You can take a look at following resource to learn more to update.


The problem is solved.
It turned out not to be the updates.
I narrowed the height of the grid down to the height of the image.
That used to give problems, but now I turned on the button “respect aspect ratio” and that solved it.

Glad you sorted things out and thank you for sharing the solution.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.