Revolution slider video not starting unless clicking somewhere

Good day!

I’m kinda puzzled about this one, the function is working as expected with the exception that I need to click basically ‘anywhere’ (not necessarily inside the revslider) in order to trigger the videos to play on hover. The issue is with the three (yellow, red, blue) category tabs below the header image. Any ideas?

The address to the build site:

Best regards


Hello Patrik,

Thanks for writing to us.

I checked your website It seems that you are using the Revolution slider for three tabs. Please have a look at the documentation of Revolution slider about how to set video controls in the slider.

If it doesn’t work for you, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


To clarify the issue - everything works as expected, but only after clicking anything within the browser window. The behaviour of the slider is working in all other aspects.

Hello Patrik,

Thanks for providing the information. When I test your site again, the slider is working as expected. What did I do? I have cleared your site cache first since you have installed LiteSpeed Cache and then I changed the slider Spinner to #6 so that I will know that it is loading the latest site changes and not the old cached version.

Kindly check your site now.

Hi Ruenel!

Thanks for your help!

Weirdly enough I still cannot get it to work in Chrome from my end, tried deleting cookies, hard reload and clear cache etc. But at least I can get it working in Edge so that seem positive! Did you test it in Chrome from your end by any chance? Make sure you don’t click anywhere when testing - reload the page and just hover the three columns with the mouse and see if the video starts (in chrome)

Update: I have now tested it on three different PC’s in Chrome with the same issue still present :frowning:

Hello Patrik,

Please check out my screen capture and take notice of my cursor as I did not click anywhere.

Hope this helps.

Hi again!

Ok, the issue is when you hover either the yellow “Webb” the red “Design” or the blue “Media” it should trigger a video, but it only works when clicking somewhere on the page

Good day! Just checking in on the progress - I can see you’ve done some change with the sliders since they do not display any text anymore - let me know if I can be of assistance!

Hello Paul,

Yes, I can confirm that the mouse enter and mouse leave interaction were not recognized. This could be a bug in the latest release. We will investigate further regarding this issue.

Thank you for your understanding.

Ok understood, please keep me posted on the progress so that I know when I can launch the site!

Hey Patrik,

I have cleared the cache of Autoptimize and Litespeed and deactivated them and the videos play upon hover so this is not a bug.

When reporting an issue to us, please always clear all caches and deactivate optimization, if not all 3rd party plugins so we can focus on the plugins we bundle only.

Please note that I’m not supposed to touch your other plugins but I had no choice. I had to show you the result. See the video in the secure note. I’d like to add that I didn’t click anything in the screencast. The videos play just by hovering.

Hope that helps and thank you for understanding.

Hi Christian!

Yes I’ve been doing some optimization tests today since I didn’t know if there was anyone working on the page. I am testing the site, done a hard reset / empty cache with the optimization plugins deactivated, tested on two different PC’s with Chrome (along with a third one earlier) - no change: videos not playing unless triggered by a click of the mouse. But it works fine in Edge and in Firefox.

Hey Patrik,

Thank you for testing again and keeping the optimization plugins deactivated. That really helps us.

When I tested, I was logged in. If I use incognito mode, the video doesn’t work still so it looks like there’s Chrome takes something into account when you’re logged in.

I investigated deeper and saw that your video Mute setting is off. The videos must be muted in Chrome so it will allow videos to automatically play. You can see this working in my new screencast in the secure note. Mute video 3 as I’ve already muted 1 and 2 during my test.

Hope that helps.

Wow! Thanks Christian - that is awesome troubleshooting! You really know your stuff! Thanks - it is now working like a dream!

Glad that we could be of help.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.