Revolution Slider Errors

Today suddenly it started saying this error.

Revolution Slider Error: You have some jquery.js library include that comes after the revolution files js include.
This includes make eliminates the revolution slider libraries, and make it not work.

To fix it you can:
1. In the Slider Settings -> Troubleshooting set option: Put JS Includes To Body option to true.
2. Find the double jquery.js include and remove it.

Please help.

Its working fine when i set this on Global settings.

Defer Javascript Loading = ON

But earlier it was working fine without enable this option.

Hi Siddharth,

Thanks for writing in! Did you try applying those troubleshooting options mentioned above ? If not, you can refer to the detailed guide here (

If you have a caching plugin (for example W3 Total Cache plugin or similar), you need to purge all possible caches before testing. Please refer to the following guide on how to clear all caches (

Also if you’re using any CDN service like CloudFlare, you need to login into your CloudFlare account and clear it’s cache as well before testing.

If you’re still having issues, please provide us with your WordPress login credentials in a secure note to check your issue further.



Yesterday it was working but today the complete slider stop working.


The Scroll Bottom Anchor also not working.

Hey Siddharth,

I tried checking your site and there are some Javascript error which are most probably the cause of the issue.

Have you added some custom code in the child theme of the site to defer the loading of javascript? If so, please try remove the code.

Please also try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

If the issue persists, please provide us with the admin access to your site in a Secure Note:

Please check above the notes.

and the slider problem exists with the main page only. i had tried with a alider test page, its working.

Please check what is the problem with the front page.

Gotcha! it’s very hard to troubleshoot the issue because it’s not coming from the Revolution Slider nor on the Theme.

It’s coming from the Mailchimp Signup Form custom code that is on the footer (Content Area Modal). There are scripts there that are not supposed to be there but on the <head> tag. You can use your Insert Headers and Footers plugin for that.

Or better use the shortcode [tco_subscribe form="617"] like what you did on your test footer (Copy of Global Footer). That is the reason why the slider is working on the test page because the test page is using the test footer which does not have the Mailchimp Signup Form custom code.

Regretfully, we cannot provide support for Mailchimp you need to contact their own support if the issue persists or if you need assistance on integrating that custom form code.

Hope this helps,


Okay. whether it working without the Mailchimp code ?

Hi Siddu,

Yes, you can try temporarily disabling or removing the custom code and it should stop the error on the site.

Hope this helps.

Hey, yup its working.

I don’t understand around 3 days before everything working fine but suddenly it stop working.

i think earlier i had email form shortcode.
After added the mailchimp code the issue started.

So what is the best way to resolve this issue with having the mailchimp signup form.

Hi Siddharth,

Yes, that is more likely the case.

I suggest, instead of creating the form on the MailChimp end. You use a plugin so you only need a shortcode for adding the form to your page.

You can try the Email Forms extension.
or the 3rd party Mailchimp for WordPress plugin
whichever suit your needs.


Sure, I will try.
Thanks for your help.

You are most welcome. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.