Revolution Slider Error: Failed to load Stream youtube/facebook/instagram/twitter etc

i’m having a issue where i keep getting the following message: Revolution Slider Error: Failed to load Stream
i do have stream wrapper enbaled
i do have the latest theme and plugin
i do have api and key added
i do have strema image added
i have given my my wp folder to added everyone
plugin all disabled excpect conrnstone and revslider

what else can i do ?

Hi @irontamoor,

Please check this link from the Rev Slider documentation for instructions:

In case you are still getting an issue, please provide us with the admin access to your site in a Secure Note:

i have done all those checks i have added my facebook api, unfoamntly my website is only on my computer which can only be accessed by teamviewer

Regretfully, we only provide forum support. We could not do a TeamViewer support.

Please upload your site to an online server so we could check.


Please provide us with WordPress Admin access also.

I’d also recommend that you try the common solutions listed by ThemePunch at


i have added the information and already checked the link.

Hey @irontamoor,

Thank you for providing WP Admin access. Upon checking, I saw that Cornerstone is out of date. I updated it by uninstalling it then going to X > Validation to let X install Cornerstone automatically.

It did not resolve the issue though so I then tested installing and switching to the default WordPress theme but still the issue persists so this is not a conflict with our products and Slider Revolution.

It is weird that the slider works in the preview but not in the frontend. There is a PHP warning in the frontend which the issue could be related.

Warning: count(): Parameter must be an array or an object that implements Countable in...

That warning is commonly related to PHP 7. Slider Revolution is compatible with PHP 7 but there could be a PHP 7 feature that was enabled that is causing this issue. I currently have no idea what it is though so please:

  • try downgrading your PHP version to 5.6
  • try replicating your setup in a different web host. Just a tip, there are web hosts that offer free development site like This is so we can rule out web host conflict.


how did you get the preview to work? i look in preview and get the error message **Revolution Slider Error: Failed to load Stream **

i downgraded to 5.6 and same issue diffrent host will take time

Hi There @irontamoor

I have added the slider preview that I see to the secure note below.

Can you also try switching to a different PHP version you have on your server and test this issue further. The best method is to test it on a different host as mentioned above by @christian_y


system is now on 7.3

Hello @irontamoor,

Could you please double check the ftp details because it is not working.
Please have it updated.


updated in orginal post

diffrent host same issue

Thanks for testing. Your FTP credentials still doesn’t work though. Please double check.

I have tested on several of my test sites as well and I got the same error. I checked the error logs and there’s no error related to stream wrappers so the issue could be coming from the FB App setup. It seems that everything was setup correctly in my test though.

And, the last time I checked in your site, the slider was working in the Preview. When I checked again, it’s not working anymore.

Regretfully, this will need further investigation. I’d recommend finding an alternative if you have a tight deadline for now.

Thank you for understanding.

updated my ftp host url do you need my FB details to help with this.?

Hi @irontamoor,

I have check and can confirm settings here:
Now, please also share FB details. Let’s just confirm if settings is correct. Also, I am able to access your site FTP, I can’t see the error log. Can you check with your hosting and see the content of error log? Thanks.

Facebook login given and I will contact Hosting provider

I got a notification of a sign in n Facebook.

Hi @irontamoor,

Please double check your facebook API setup. On revslider settings, you have added a Facebook Page. Then when I check the current API you have set, there’s no Facebook page attached to it. This Facebook page should also exist on the API setup.

*Edit. That is me logging in on Facebook checking API settings.