Rev slider you tube video no sound or controls

My rev slider you tube video do not have sound or controls. I have turned off the muted switch. Please see attached screen shot.
Please Advise.
Thanks in Advance : )

Hi Salim,

Thank you for writing in, it seems you added your video as a background, background-videos does not show controls, please add your video as a Video Layer instead.


Thank you. I made the video a layer but now it is not centered and half of it is being cut off… Im not sure why. It showing up centered on mobile but its not playing at all and there arent any controls showing.
Here is the url:
Thank you


Try to change the aspect ratio of your video

Then make sure Hide Controls is turn off and Play Video Inline is enabled

For more information kindly refer to the link below

If that does not help, please provide us wordpress admin login in Secure Note



Unfortunately, that did not work. I will attach my credentials. Thanks so much.

Hi There,

I’ve enabled the Stretch Element option and the video is fullwidth right now:

For more information, please take a look at this article:

Hope it helps :slight_smile:

Unfortunately, the sound is now not playing and I would like to keep with the same design I had (attached video). I would just like it to fit in the container properly. It fits fine as a background video but then there isnt any sound or controls so it must be a video layer. Is there a way to fit the video layer in the container? Thanks

I turned off Full Screen and Force Cover and you video’s now centered unlike before.

The video is muted because autoplay is on. It is a new feature of modern browsers because websites with auto-playing sound annoys most users. Playing the sound while enabling the autoplay is something that would require custom development which is outside the scope of our support.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.