Remove post date only on post page

I’d like to keep the author and category.

I saw this topic

which has this fix…

.p-meta span:nth-child(3)::after {
display: none;
.p-meta span:nth-child(3) {
display: block;

But I would like to keep the author.

Hello Clefler,

Thanks for asking. :slight_smile:

You can add following CSS under Pro > Theme Options > CSS:

.p-meta span:nth-child(2), .p-meta span:nth-child(3) {
display: none;

I have found the proper CSS code selector using the Chrome browser Developer Toolbar:


Thank you, that worked except the second child needed to be child(2) again for some reason.

Also, I tried to apply this to a category of posts under theme options, is there some reason why this wouldn’t work?:

.category-sermons .p-meta span:nth-child(2), .p-meta span:nth-child(2) {
display: none;

Hi again,

Your code works fine, I checked your code via Chrome’s developers tool. You’re just seeing the cached content, please clear all caches (plugin + browser + CDN if using) and check the page again.

Always make sure to clear all caches after making any change so you can see the changes on the front-end right away


Hey thanks for checking but I don’t think it is the caching plugin. I don’t see a change after clearing the cache or even another browser.

Hello @Clefler,

Since you already cleared the cache, I am suspecting that there is an invalid entry in your css which created this conflict and why the code did not work. Please provide the css code you may have added in your site so that we can check it. Or maybe you can load it up in csslint ( to look for errors in the code.

Hope this helps. Please let us know how it goes.

The code I added is the what I pasted above…is that what you mean?


Are there any existing css code before you added the code provided by my colleague?

Would you mind providing us with login credentials so we can take a closer look? Please provide following information:

Set it as Secure Note

  • Link to your site
  • WordPress Admin username / password

All the best!

sure, you will find it at the bottom of the css in theme options

Hello @Clefler,

Your code did not work because of this invalid css entry:

border: 6px solid rgb(229, 229, 229);

I already corrected this by commenting that line. I cleared your WP Rocker cache as well.

Please check your Sermons category page now.

yup, looks like you fixed it…thanks so much!

Glad we could help.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.