"Raw Content" element supports "Textarea" tag?

I use latest version of X (8.0.10) and cornerstone. When I add a “Raw Content” element, then add test, the element will display as “This element could not render due to invalid markup. You may have unclosed HTML tags in your content”.

Example page:

Hello @cuixu,

Thanks for writing to us.

It might be the issue of the HTML markup syntax error or plugin conflict issue, CSS/JS customization issue. I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing for Plugin Conflict
  2. CSS/JS Customization
  3. Version Compatibility
  4. Disabling Cache

If it doesn’t work for you, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password
  • Exact page URL

You can find the Secure Note button at the bottom of your posts


Still not working, so I shared in secure note

Hello @cuixu,

Your custom HTML code contains <script> tag which is not allowed on the element. Please make use of the classic raw content instead. Though you will not see any preview of your code, the actual output can be seen when you view the page live.

See the secure note.

Check your site now.

I tried and unfortunately it won’t work in FireFox or Edge (please try https://www.biz-genius.com/tools/extract-email/). This is the exact reason why I switch to “Raw Content”.

Strangely enough, Chrome display the content correctly.

I also tried removing the “script” part. I think it is the textarea tag which caused the problem.

On a separate topic, how can I get an email alert when you reply?

Hey @cuixu,

The message “This element could not render due to invalid markup…” is caused by the textarea element and I believe this is a bug so I’ll post this in our issue tracker so this will be queued for further investigation by our development team and if found to be a bug, they will release a fix for this in one of the succeeding updates.

Regarding scripts, it should be accepted by the Raw Content element. There could be a bug in the Classic Raw Element why it outputs the actual code on Firefox. I’ll report this as well. For now, please use the Raw Content element and not the Classic Raw Content. Alternatively, you can move your script to the Page JS. Just DON’T include the <script></script> tags.

Hope that helps.

I tried and put the js code into PageJS, but it still does not work under firefox or Edge: when clicking the “Extract emails” button, it does not do anything.


What should I do now?

Hello @cuixu,

Aside from removing the Script tag and add it to the custom JS section, you will have to enclosed any fold field like the textarea with a <form>. Please update your code into this:

		<textarea id="email" rows="5" style="width:100%">There are some emails here linda@abc.com and s09@stanford.edu. No there are more such as jacksmith@japan.edu.cn.</textarea> 
		<button onclick="reverseEmail();return false;">Extract emails</button>

Best Regards.

Thank you @ruenel

However, under Firefox, when I click the “Extract emails” button, nothing happens. It sounds like the button onclick parameter is gone. In Chrome it works fine.

Do you have any fix?

I found a workaround.

However, I think it’s still a bug where textarea can’t be used alone, and js can’t be placed in raw content.

Hello @cuixu,

I am using Firefox and this is how your page works:

Be advised that the raw content element or the classic raw element only displays the code. Any behaviour of the resulting display will be controlled by the code or how the browser renders the code.

Thank you for your understanding.

Hi @cuixu,

Thanks again for bringing this to our attention. I can confirm it will be fixed in the next release.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.