Problem with The Grid's lightbox

The page contains a gallery (below the blog archive) built with The Grid. If I use Chrome to click through the images, the first one displays OK in the lightbox but the rest more than fill the screen - they are zoomed all the way in. On Edge, it works as expected.

This is a new problem - but I don’t know whether it arrived when I updated WP to 5.6, or X to 8.x.x.

I’ve tried changing the lightbox from The Grid’s native one to Foobox(v2) but The Grid doesn’t recognise that Foobox is available (even though Foobox is activated and working with images).

Here’s how it should look (from Edge):

… and how it looks on Chrome:

I have tried clearing all caches. The problem still occurs in an Incognito window.

Thanks for your help.

The problem also occurs on the development version of the site at - which uses no caching.

Hello @mikerayjones,

You may be having some caching issues. It could also be caused by a plugin conflict, amongst other things. Please check out this troubleshooting article here and follow the instructions for the following sections (where appropriate):

Testing for Plugin Conflict
Disabling Cache
Disabling CDN

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Thanks @ruenel. The problem was resolved by upgrading The Grid from vs 2.3.0 to 2.6.0.


Hey Mike,

It is good to know that your issue is now resolved.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.