Problem with one page scroll on Chrome (desktop)

I’m developing a one page website with X Theme (child).

On Chrome desktop, when clicking on a menu item, the page “jumps” to the anchor instead of scrolling to it like it’s supposed to. Any other anchor link on the same page scrolls properly (e.g. top link in the footer). It’s just the menu items who doesn’t triggers scroll.

The problem only occurs with Chrome in desktop or “no touch” mode.
If I run Chrome development tools and select mobile or touche device preset, the scroll is working.

It’s working fine in Safari and Firefox.

The theme, child theme and plugins are all up to date.

I tried with all plugin disabled (except cornerstone and wpbakery, otherwise I don’t see any content).
Removed all additional JS.
Removed all additional script in child functions.php

The problem remains.

Can you help me figuring out what’s happening?

Hello @megatone,

Thanks for writing in!

I have already inspected your site and I found that you have set up one page navigation incorrectly. You should be adding the ID to the content bands or sections and not on the column. Please try to create another set of menu and use #x-content-band-3 for Murals, #x-content-band-4 for Studio, #x-content-band-10 for Prestations, #x-content-band-17 for Shop, #x-content-band-22 for About and #x-content-band-25 for Contact.

If you want to have Custom ID to make your menu links more presentable than having just{n} , I would recommend that you recreate your page by using Section element or simply create another page and use Cornerstone in building it instead.

Hope this explains it briefly.

I made the change and it doesn’t resolve the problem. It still “jumps” to the anchor on Chrome.

Hey @megatone,

In that case, please give us WordPress Admin access credentials in a Secure Note so we could check your setup in the backend.

  • If you have changed the default login URL, please give us the custom login URL
  • Provide us with admin level username and password.


I added credentials above.

Thanks for your help!

Hey @megatone,

I’m sorry I just discovered that this is a bug with the X’s menu. I’ll post this in our issue tracker so that it will be queued for fixing.

For now, using UberMenu works. I’d recommend you use UberMenu for now. In case you’re not aware, Ubermenu is bundled in our theme. See

Hope that helps.

Thanks for your responses!

I tried UberMenu and it seems to do the work.

But it significantly change the apparence of the menu (even with no skin), especially in mobile mode.
I need to do some CSS works but I don’t have time right now since I’m supposed to deliver tomorrow.
So I managed to make a simple custom JS to bypass the problem, but it’s not a clean solution.

I will see later if I change to UberMenu or wait for the fix to be released.

Is it possible to get notified when the fix is available?

If not or if it’s not the right channel to get notified, you can close the topic.

You’re welcome! Unfortunately, we can’t provide ETA about bug fixes, but of it is added to changelog once available. Thanks!

Hey folks,

I believe that I’m seeing a similar issue on

The buttons smooth scroll to anchor, but clicking the link from the main menu causes the page to jump to the anchor.

Or maybe there’s another issue with my code?

I’ll keep my eyes on this thread for an update. Thanks!


Once our developers have fix this, it will be rolled out in the next release update cycle.
Thanks for understanding Luke.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Hi everyone,

Thank you for your patience as this issue has effected your sites. In the next update (scheduled for this afternoon) this issue should be resolved.