Problem to change fonts


i want to change my fonts on the website in RotisSansSerif55. I create the font with the Font-Manager in Preferences but it doesn’t work.

Hi FurtFan86,

Upon checking your website, I could see that you’ve updated your Cornerstone plugin to the latest version but NOT updated the X theme yet. Please update it to the latest version as well.

Here is the update guide:

And the changelog:

Hope it helps :slight_smile:


no, it doesn’t help. The fonts are not changing.

Theirs an other problem. The footer-content will not be displayed.


Hello Lennart,

When you add a custom font in the font manager, you will need to upload ALL the necessary font files. It must include the *.ttf, *.eot, *.woff, *.woff2 and svg for cross browser compatibility.

Your footer contents is now visible. I went ahead and updated the css to resolve the issue.
I used this:

.x-colophon.bottom .x-social-global a i,
.x-colophon.bottom .x-colophon-content a,
.x-colophon.bottom .x-nav li a{
  color: black;

Hope this helps. Please let us know how it goes.


can you please try to change the font once? If i do this with Options–>Typo, it doesn’t have any Effect. I Changed it from Rotis in Inherit and Headings. I think that currently the default font is output.


Hi Lennart,

There is a font error in your site:

Failed to decode downloaded font: .../wp-content/uploads/2019/02/RotisSansSerif55.ttf
(index):1 OTS parsing error: cmap: Failed to parse table

Perhaps this link could help you:

And to properly install a custom font, please review “Custom Font Manager” section in this changelog:

Hope this helps.

Okay, thanks.

Hi there,

You can read more information about the Font Manager here:

Hope this helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.