[PRO] Unable to edit header


I have recently redesigned a website and I was working from a subdirectory. - it has now been moved to the main domain, however, I am unable to edit only the header in the Pro editor. I have gone through the thread that suggests a few fixes (https://theme.co/docs/warnings-in-the-builders) but I haven’t been able to resolve the issue.

Let me know if you need any more information.

Thank you

Do you get an error message about a different URL for the preview? Something like this?

Yes, exactly that!

No matter where I look, I can’t find the culprit either. Both URLs are the same in the backend here, both are https://. The most peculiar thing is, this is for headers only. The preview of content works without any issue. I haven’t tested this with the footer though. I guess I shall take a look here as well. I have not footers on my pages.

Reading the posts here, this is not the first time Themeco needs to deal with that. There are no other solutions like “check the urls in genereal -> settings”, “disable plugins”, “talk to provider”… At this point, what provider offers support for WP which is not their own installation? lol… What does themeco think we do first after we realize a mismatch in the URL? Let me think… what about “empty cache”.

Hey Ondrej,

To better assist you with your issue, kindly provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

In the meantime, install Better Search and Replace plugin. You need to search for https://subdomain.example.com and replace it with “https://example.com/”.


Be very careful with “Better Search and Replace”. If you change the URL and somewhere in your pages is this as a part of some essential function or script, it may break it and you loose the functionality. So you might be rebuilding this part after “search and replace”. In my case I was lucky, it was just one plugin output, that broke and I had to reset it. I’ve got “invalid JSON response” errors in mozilla. Rebuilding, clearing caches, all runs just fine again. Even the header editor. Kudos to ruenel at this point.

Hi Rue,

I have provided my details to you. Let me know how you get on.

Thank you

Hi @bencroftweb,

I have checked your site and found the Content Builder is loading the Header content. Can you please check by clearing all type of cache, and in private or incognito mode.

Hope that helps.

Hi @tristup,

I have deleted all cache from chrome and firefox but it still comes up with the same issue, I have dowloaded different browsers it is still happening. Should I try installing a cache plugin and see if that helps? - could the site itself be caching the old domain?

Thank you for your help!

Hi Ben,

I have checked in different ** browsers** and different ** locations** but the result was the same, and it seems that the issue is with your end only. I suggest you consult with a local developer who can inspect and investigate the issue specifically at your machine.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.