Pro theme: why is my site not loading faster?


My site is very simple: 0 pages, 2 headers, 2 footers, 135+ active post, 3 Grids: index, search and archive, plus a few plug-ins and a bit of CSS; main page is set a blog content.

When it loads, it is noticeably structuring its Grid masonry format like you can see the post getting in position, and slow to load, not the best user experience to my mind… I thought that I removed any animations from the Grid, use image compression tool, lazy image load, caching, etc.

Check it out:

Any ideas how to improve its loading time, especially its first load (before it’s cached)?

Thx, Lio

Hi Lionel,

Thanks for reaching out.

Regretfully, providing a solution about site speed is outside the scope of our theme support but I will give you some idea why your website is loading slow. When I check your website on Gtmetrix and Google Page Speed, the images are not properly served scaled, there are also some images that need some optimization and I guess your lazy load image is not working properly. For more information, please check our docs on how to improve the site speed..

Hope that helps.

Thank you.

Hi Marc,

Thanks for the response.

I follow the guidelines from the docs but can’t really say that performance is better with the extra plug-ins and tweaks.

I have compressed and resized down all images using free plug-ins, no big change… I perhaps reduced them by 5-10% only as they were already compressed.

Some reports suggest that my HTLM and CSS files are too big. How can these be optimised as they are based on the theme or the use of its partner plug-in The Grid?

BR, Lio

Hi Lio,

I have inspected your site and it is 2MB in size with 69 requests which load in 1.38 seconds.

Check the necessary things you need to fix in the site to make it load even faster. Meanwhile, kindly check out our other Performance video tutorials here:

Best Regards.

Hi @ruenel
I had a look at the suggested video and give it a try with autoptimize… it broke something as after I installed it, I am not able to edit my pages through cornerstone. And to make it worse, I am not able to remove the plug-in after deactivating it!? Any suggestions to fix this mess?
BR, Lio

Hi Lio,

Please clear your Autoptimize cache and then deactivate the plugin. It should be back to normal assuming that you do not have any other performance plugin installed or that you are not using a CDN or CloudFlare. If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Thanks @ruenel … I managed to remove it by manually by renaming certain files / folders from my webspace as it appears (according to another forum) that autoptimize and other plug-ins were conflicting. I removed them all. After that, Cornerstone is working again.

So I tried a basic test using as you suggested:

  • with no caching plug-in (without autoptimize): load 3.5sec
  • with autoptimize with the suggested basic config per the tutorial: load 4.2sec

Not sure what to read from this test, but not convinced performance is improved by such plug-ins…

I seem to have less than 1Mb of images (my site is a blog, so is that normal size for images?) and over 30% of load time relates to scripts.

Not sure what to do next with this info…

BR, Lio

Hi Lionel,

To better help you with your concerns, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.