Pro Editor Not Working - Not Loading Correctly


After updating the Theme and Wordpress, though the site is working, Pro Editor is not displaying correctly. It somewhat looks like the stylesheet did not load and is very similar to the problem here: (though this was with an X version and Cornerstone).

A few things I have tried to help the issue are:

  1. Increased memory limit by adding code to the wp-config.php file define(‘WP_MEMORY_LIMIT’, ‘512M’);
  2. Double Checked PHP version updating from 7.1 to 7.2
  3. Deactivated all Plugins, only to see the problem still remained after doing so.
  4. Made sure the theme, Wordpress, and all plugins were up to date. I am running Wordpress 5.0.2 and Pro 2.4.6.

Thank you!

Hi Amber,

Thanks for writing in! By looking at your screenshot, the possible causes are as follows.

  1. Pro theme may have been corrupted: Try deleting your Pro theme and then re-install it and see whether your issue is resolved. To do that, you can switch to a default WordPress theme by head over to Appearance -> Themes section and then delete your Pro theme. All of your current settings will be saved in the database, so that you can safely delete your Pro theme. Then download the latest version of Pro theme from your Themeco dashboard, install it and test your issue further.
  2. Child theme issue: If you’re using a child theme, temporarily disable your child theme by activating your parent Pro theme and see whether your child theme customizations are causing this issue.
  3. CloudFlare like CDN service: If you’re using a service like CloudFlare, you need to login into your CloudFlare account and purge your cache as well. Also make sure to disable CloudFlare rocket loader and CSS/JS minifications under the Speed tad.
  4. Caching: If you’re using a caching plugin like W3 Total Cache or similar on your site, you need to purge your server cache and also clear your browser cache before testing. Please refer to the following resource for more information on clearing cache (
  5. Regenerate your .htaccess file: Head over to Settings -> Permalinks section, then select the option postname and save the changes to re-generate your permalink settings. Then re-test your issue again.
  6. Clear Pro style cache: Make sure to clear style cache under Pro -> Settings section (see bottom of the page).

If none of the above solutions helped in your situation, please provide us with your WordPress login credentials in a secure note to investigate your issue further.


Thank you for the suggestions, unfortunately none of them solved the issue.

  1. I deleted and downloaded the theme again and there was no change.
  2. I do not use a child theme.
  3. I do not use CloudFare.
  4. I am not currently using a caching plugin.
  5. I currently use Post Name. I did select a custom structure just with /%postname%/ and saved those changes, but it reverted to the Post Name selection again. I hesitate to change it to something else for SEO reasons, but just saving the options did not fix the issue. If you really think this could be the problem I can try changing the structure to something different and then change it back to see if that helps.
  6. This did not fix the issue.

I do want you to know that is it this way for all Pro settings (Headers, Footers, Content, etc). I will add a secure note with login details, thanks!

Hey Amber,

Usually, updating WordPress is the solution but in this case, your server is blocking or is not supporting the (text/html`) MIME type for stylesheet. This might be due to a security configuration.

We will need for you to cop your site over to staging environment because we need to see if Pro is conflicting with your server and no third party plugins is causing this.It’s not possible to investigate in your live site as there is a risk of breaking it and troubleshooting will affect your site’s operation.

After you’ve done that, please give us the staging site’s WordPress Admin and FTP access.


I will set up the test site and get back to you when that is complete. I do have other websites on the same server that are also using Pro. I went ahead and updated one to the latest version of Pro with Wordpress and all my plugins also updated, and it does not have the same issue, so it is unique to this one site.

Hello @ArizonCo,

Thanks for the updates. I have logged in both of your sites and compared your settings. You are experiencing the issue because of the incorrect site URL settings. Please go to Settings > General and make sure that the Site URL and the WordPress Address URL is the same as your dashboard url because the Pro editor will be using that settings in loading the editor. Once you are done building the site or finished editing a page, you can change it back to the same settings you are having.

Hope this helps.

I will try that, but the Wordpress site is downloaded under the folder, but for obvious reasons I don’t want that showing for everyone when they are visiting the website, this was the recommended way to set it up when the site is downloaded under a folder by Wordpress.

Was there anything in the recent theme updates that would have made this incompatible? I have had it this way for several months with no issues, until the most recent theme update.

Thank you!

Hello @ArizonCo,

Since the release of Pro theme, it is working that way. The editor uses the Site URL setting to load the preview.
Please check this out:

Hope this helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.