PRO builder not loading due to http/https mismatch

Hello team,

The pro builder is not loading on our site due to an issue with the protocol mismatch. It is multisite, and we noticed that in the installation, the base URL and site URL was set to HTTP for the parent site while installation, while the site is SSL secured. So, for the Pro Theme, they show the preview using the base URL, and it is getting redirected to HTTPS causing it to show a mismatch error with HTTP and HTTPS in the site.
We were able to make the changes in the subsite( from the Network Admin > Sites > Edit page and changing the base URL and site URL. So the original issue was rectified. However, we would still get the error with the Pro theme on the parent site(, as we are not able to change the base URL and site URL from the admin panel.
We tried certain suggested methods such as performing a search and replace in the database tables for making http:// instances into https:// in various entries and by defining WP_HOME & WP_SITEURL in the wp-config.php file, etc. None of them worked so far. Can you please let us know what exactly is the cause of this issue with a possible solution?


Hello @atjonesen,

Thanks for writing in! Please go to Settings > General and make sure that the Site URL and the WordPress Address URL is the same URL as your WordPress dashboard.

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

I found that spot and sure enough, our wordpress URL and our site URL are both showing as http:, but we recently added the SSL and that seems to have tricked the “Edit in Pro” to search for https: - what can I do?

Hi @241sports,

To further help you with your issue, we need to check your WordPress admin. To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi Marc -

I sent two secure messages over 18 hours ago and have not heard back from anyone. Are you able to help?

Hi @241sports,

Unfortunately, we didn’t find your site details in the secure note, can you please check and resend it once again.


Can you send me a note with exactly what you need and then a spot to send the secure note?

I’m all set. My hosting plan sorted me out - it was a conflict with the new SSL and they needed to change everything to https:

Hi @241sports,

Great that it sorted out at your Hosting end. Now if you need to replace the URL of your site with HTTP to HTTPS, I would recommend you to perform the URL replacement another time with any plugins from the WordPress repository.
There are many URL replacement Plugins available in WordPress, this article will be helpful:

Hope it helps.

OK - did all that and now that I am (was) up and running, every time I make a change on certain pages in “Edit with Pro” - the whole site shuts down and locks me out even to login for about 20 minutes -and then unexplainably, comes back up. Any ideas on what is causing this and what can be done. My site has been a mess since i updated to the current version and added an SSL.

Hello There,

Please see the secure note.


I don’t see the secure note?

We have added the site credentials (Secure Note) here and to our first note as well, please have a look.

I remain confused. Are you asking me to share site credentials with you? - Or, are you saying per you wording that you have added site credentials and have shared a secure note with me?

Hello @241sports,

Sorry for the confusion. Our reply was meant for @marc_a, @ruenel, @tristup or any to the @Themeco staff to check our website with the site credentials provided by us, as a secure note. Our site is experiencing a weird issue while trying to use the ThemeCo Pro Theme X Builder as shown in the first note.

We have been over this issue for a month now.

Any help would be appreciated.


This has been resolved internally. Thanks.

Glad to hear that, @atjonesen.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.