Pro 5.1.4 - Plugin Conflict - Query Monitor

Hi Themeco,

WP 5.8.2
Pro 5.4.1
Query Monitor 3.7.1

FYI there is a plugin conflict when using the popular developer debugging Query Monitor https://wordpress.org/plugins/query-monitor/

Activate the plugin and launch a Pro builder, for example Header Builder and select a header to edit. Open the browser developer tools, you will notice the following errors:

api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

POST https://localhost/wp-json/themeco/data/late-data?_locale=user 502

_ @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

f @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

b @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

a @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

b.method.r @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

a @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

t @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

y @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

a @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

t @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

P @ api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df:2

(anonymous) @ app.6f62d0f.js:2

u @ app.6f62d0f.js:2

s @ app.6f62d0f.js:2

(anonymous) @ app.6f62d0f.js:2

requestIdleCallback (async)

a @ app.6f62d0f.js:2

n.current.Promise.then.t.current @ app.6f62d0f.js:2

(anonymous) @ app.6f62d0f.js:2

(anonymous) @ app.6f62d0f.js:2

Bh @ react-dom.min.js?ver=16.13.1:126

Dj @ react-dom.min.js?ver=16.13.1:162

unstable_runWithPriority @ react.min.js?ver=16.13.1:25

Da @ react-dom.min.js?ver=16.13.1:60

xb @ react-dom.min.js?ver=16.13.1:162

(anonymous) @ react-dom.min.js?ver=16.13.1:162

U @ react.min.js?ver=16.13.1:16

B.port1.onmessage @ react.min.js?ver=16.13.1:24

app.6f62d0f.js:2

Failed to get late app data {code: 'invalid_json', message: 'The response is not a valid JSON response.'}

This error stops the builders from working as non of the elements cannot be edited.

Hi @strobley,

Thanks for reaching out.
There might be some different reasons behind your issue, I would like to suggest troubleshooting the following common issue to help us to recognize the reason.

1.Theme Related Issue
2.Plugin Conflict
3.Theme Update related issue
4.Child Theme Related issue ** if you have activated it.
5.CSS/JS Customization
6.Disabling Cache
7.Disabling CDN

If you discover that an issue is coming from a custom code or 3rd party plugin, kindly consult with a developer or contact the plugin author. Please note that we do not provide support for custom codes and 3rd party plugins.
If none of the above helps and you are still getting the issue, please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access in the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.

NOTE: I have checked your Themeco Account but didn’t find any website listed, please add the site into your Themeco Account for further support. If that is in the local environment, please upload and share the details for further investigation.

Thanks

@tristup I do not understand your response.

I have explained the cause of the issue. It is a conflict with the Query Monitor 3.7.1 plugin. Activating this plugin cause the error and builders not to work. Deactiving allows the builders to work without error.

I am highlighting is as Query Monitor developer plugin, @alexander maybe interested given the popularity of the plugin.

Hey @strobley,

I am another staff checking in. I have here my Pro 5.1.4 with Query Monitor 3.7.1. I could not replicate your issues. Please check out my video screencast:

Thank you.