Preview is not loading in cornerstone

I have created a staging site on Godaddy managed wordpress hosing. I have uninstalled all plugin except cornerstone but getting the same error. The error message as follows
“The preview couldn’t load. This is most often related to a plugin conflict or aggressive page caching. Checking the developer console for errors could indicate what wen wrong.”

Hello @yogajitsu,

Thanks for asking. :slight_smile:

Would you mind trying these general solutions.

  1. Ensure you are fully up to date. See our changelog.
  2. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.
  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  4. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS, Javascript and templates.
  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  7. Contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

If nothing helps, please give us WP Admin and FTP access in a Secure Note.


Thank you very much for your replay. I haven’t installed cache plugin as well as I have no idea about CDN. I have rename the .htaccess file and increased the memory limit and still getting the problem.

Hello There,

Thanks for writing in! Did you inserted html or custom code in your page? Please make sure that you use raw content element and not the text element. And also, you will have to make sure that all your custom codes are valid and correct. One missed closing </div> could mess up Cornerstone or even the whole page layout. To know about the preview warning messages and how you may resolve them, please check this out:

Hope this helps. Please let us know how it goes.

Hi There,

I can see now that you have basic setup. No extra plugins, caching and no extra settings. Just plain vanilla wordpress setup. I have also login via FTP and then check error log but then I can’t see it. I have checked each of your pages too and I saw the error even with pages that there’s content. I then check the console and notice the following error:

Since I can’t find the error log at the moment, would you mind asking for it from godaddy? Let’s see if we can find more details of the error. Thank you.

Hi, I’m just following this post. I’m having the same issue. I talked to GoDaddy and my site has no caching. The only changes were a WordPress and a X-Theme update.

I solved the issue! I hope this is helpful to someone. It turned out to be the permalinks. For some reason the update to either Wordpress or X-Theme screwed up the permalinks. I simply changed the permalink settings and all is right with the world again! :smile:

Glad to hear it and thanks for sharing the solution!

how are you?
I spoke with godaddy, they said thre was no error log but he turned on debugging mode so errors will start to populate in the wp-content folder. How can I found the error log? Can please check that error log?


Hi there,

There is no error being logged, but it looks like due to cache as it works okay when default permalink is used. The cause of the issue is the NONCE value not being regenerated and it’s common on systems with an internal cache.

I’ll continue checking later as looks like you’re working on it as I’m getting kicked out while testing :slight_smile:


Still I am waiting for your message regarding on error log.


Hi There,

The debug.log file can be found under /html/wp-content/ directory, the error is about Constant WP_MAX_MEMORY_LIMIT already defined, you might want to remove the WP_MAX_MEMORY_LIMIT you added on the wp_config.php file, the other errors are from gd-system-plugin please ask the GoDaddy support regarding this.

Though it seems those errors are not the cause of the issue as I was able to open your homepage in Cornerstone (see screenshot), the issue seems to be from the AWeber Web Form Generator code you added on your page.

Please split up that codes, place the JavaScripts on the Theme Options > JS. Place the CSS on the Theme Options > CSS and Place the HTML part on a RAW Content element.

Hope it helps,


I couldn’t open the home page with cornerstone. can you please remove the AWeber form so that I can open the home page with cornerstone and edit the page. I will add AWeber form by myself again.


Hi There,

I was able to remove the AWeber form on your page and that resolve the CSS code showing on the frontend. But now I’m getting the aggressive page caching error. Would you mind contacting your host and ask how you can temporarily turn off that caching?

And this error invalid_user: true, message: "nonce verification failed." is most likely related to security. It seems this is also the reason why we’re always kicked out from the site and login from time to time. Please confirm to your host that there is no /cornerstone-endpoint uri that is being blocked by the mod_security


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.