Post grid portfolio filter not showing

Hi Guys,

Just a quick one that’s baffling me. The filter option on post grid for x-portfolio is not working.
No filter appears.
It works fine on posts, just not x-portfolio.

I’ve checked for css confilcts by removing all custom css - still no joy.
Also tried loading it in on new page. Will keep on trying soutions and will let you know if I resolve the issue.

In the interim, thanks in advance for your help :smile:

Ref link:



Hi Claire,

Upon checking, I can see that you are using visual composer to display your portfolio items.

If you would like the filter to appear, you need to use xtheme’s native portfolio layout.

Kindly review the link below for your guide.


Wow. Has that changed recently? I’ve been using both x and x pro for some time now and previously, I was able to add the filter just like I’ve done so for blog posts here:

Also, the portfolio filter added via visual composer works perfectly well on another one of my sites: You can see it has been added on the homepage which is not the native portfolio page.

It worked previously with X Pro - I’ve just noticed it is not working with the latest version of X Pro 2.2.5

Thanks again in advance for looking into this issue.


Fixed the problem. I’d missed a pop up in the post grid settings - Phew! thought I was going loopy :slight_smile:

Glad to know that!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.