Parallax Effect not working

Hi there,

since the newer releases of the xtheme i havent been working with the parallax effect. Last week i setup a new page and saw that some things have changed, but It’s basically the same. The weired thing is, that there is no effect on this page:
But parallax is working fine on the main page in the mid sections…
Could you please take a look at this?

Thank you so much!

Kind regards,


Hey Atahualpa,

You’re using a Classic Section in the home page and that includes the classic parallax. See

You’re using a V2 Section in your new page and it has separate parallax behavior. You have not enable parallax in that section though and the parallax option is not available because you’re currently in simple mode.

Please go to X > Settings > User Preferences or Pro > Settings > User Preferences and set Advanced Mode to Always On. Alternatively, you can enable Advanced Mode under Preferences.

After that, please watch the background video tutorials below for usage instructions.


Hi Christian,

i am fully aware that i am using classical sections on main page. The parallax is working and i also now how to handle that.
I am also aware that i am using V2 elements on new page and are using parallax in the section and in the second row of this section…
I am also aware of the advanced mode…
And your links dont get me anywhere but the main forum page…

This is not helpful in any which way! If you would have really taken a look at the problem you would have seen the parallax effect activated for upper and lower layer of section 1 background… it is and was set to 140% vertical… how would i know this if the advanced mode was deactivated and how would i even know that there is a % setting for the effect?!?

Sorry, but how do you think your answer is helpful to me?

With all due respect, I have logged in and taken a look at your setup. It wasn’t obvious that you were aware because when I checked, Advanced Mode was disabled that is why I have showed you the setup. If you just elaborated more like “I enabled the Background Upper Layer parallax”, that could have pointed me to the right direction. Providing details is recommended in our How To Get Support article.

Please note that I’m answering with good and helpful intentions. I’m not questioning anybody’s intelligence here.

Now I see the problem because you have enabled Advanced Mode. I’ve also created a test page and the issue persists there also. I’ve deleted the test page after.

Something conflicts with the Parallax Script. I see a Google Map API setup issue in the console which is coming from EventOn but I temporarily set your page template to No Footer and the error was gone but the issue persists.

It’s tricky now to trace the cause since there’s no error in the console. I suspect the Essential Addons for Cornerstone might be causing this. We can’t deactivate third party plugins because it’s a live site and it might interrupt your site’s operations so you must do the testing.

If that does not help, please try deactivating all the other plugins. Please note that I do not know at this point if you have tried this. If you’ve already done this, please try re-installing Cornerstone.

I’m sorry about the links, I didn’t notice that the URL changed. I’ve updated my previous response now.


Thank you! This is what i am used to with the X support team. Sorry if i came across rude but i have high expectations for your support since most other responses are helpful right away. The support team spoiled me :slight_smile: What tipped me of were the links that were not working either. Sorry we got started on the wrong foot. For this i apologize.

Now to the problem: Thank you for testing. I will do as suggested and get back to. This might take a while but i might just go into under construction mode to figure out what is causing this problem.

I really appreciate your help and support!

You’re most welcome :slight_smile:

Let us know how it goes!

Hi there,

so i just deactivated all plugins except cornerstone and the parallax effect still doesnt work on the new page
I also deleted cornerstone via ftp, downloaded newest xtheme from dashboard and extracted cornerstone from there. I uploaded those files to ftp and reactivated cornerstone. Still no parallax effect.
Feel free to set this installation to “under construction” in xtheme settings. Just activate and the cornerstone page “under construction” is already set to be displayed. That way you can test yourself.
Tell me if i can do anything else.

Hello Atahualpa,

I have checked your files and settings and it seems okay. Once thing I notice though is that you are using CloudFlare. Please log in to your CloudFlare account and purge your site cache. And for best results, please make sure that you are using the suggested CloudFlare settings which you can found it here:

Hope this helps. Please let us know how it goes.

Hi RueNel,

Cloudflare is still deactivated…
So how can that be a problem?

Hello Atahualpa,

I have logged in again and changes the section background image settings. Not of my parallax changes reflect in the front end. My settings were saved for sure. It is somehow not rendered in the front end.

Can you please re install X theme and Cornerstone plugin? To do that, you can check out “Manual Updates” section from this knowledge base article:

Please let us know how it goes.

Hi RueNel,

thanks for the help. I downloaded the stability version and did the manual update for the theme and cornerstone and the parallax effect works now. BUT i am having issues with cornerstone now. Cornerstone won’t load in the internet explorer. All i get is a never ending loading screen. I don’t see the section menu yet nor the cornerstone loading screen.
And the search icon in the header menu is missing also.


  1. The search icon is not working because you have modified it in your child theme.

Please udpate this line of code

. '<i class="x-icon x-icon-search"></i><span class="x-hidden-desktop"> Suchen</span>'

to this

. '<i class="x-icon x-icon-search"></i><span class="x-hidden-desktop"> Suchen</span>'
  1. Since IE does not support the latest web technologies that is used in Cornerstone, regretfully, you can’t use IE. Please use chrome or firefox when using Cornerstone.

Thank you for understanding.

Hi Paul,

thanks for the feedback.
For the update of the line of code…
the lines of code you posted are identical. What do I need to update to?


Sorry about that, please update it to this.

. '<i class="x-icon-search" data-x-icon-s="&#xf002;"></i><span class="x-hidden-desktop"> Suchen</span>'


PERFECT! Everything is working again.


Your support is absolutly exceptional!!!

New Problem: I get a php error after changing that one line with the search icon. But i did not change anything else…

Warning: Cannot modify header information - headers already sent by

and now i cant update orders in the webshop.

But before the updates today in the morning it was still working.

I can’t change any pages or posts. I always get multiple php errors.

No i cant even login to the dashboard anymore with more errors…

Hello @AtahualpaSeyffert,

Looks like you have changed the login details as I am getting ERROR : Wrong user name or password. error message. Can you please confirm?

Regarding the error messages, those are warning messages that you can ignore and can be removed by editing the wp-config.php file located under root directory and then find this code:

define('WP_DEBUG', true);

And change to this:

define('WP_DEBUG', false);

Let us know how it goes!

I havent changed any login data…

I changed the wpconfig and am still getting dozens of php errors when i try to login.

Still cant login to the backend. The frontend doesnt seem to be affected by the problem.

Hi @AtahualpaSeyffert,

Please edit your child theme’s functions.php and remove the space before <?php .

You should do it through FTP.


i just donwloaded the functions.php via ftp from the child theme folder and opened it… there is no space in front of the php tag.