Page with Essential Grid will not Load all White

Hi, I am having issues with Essential Grid. I am using it to display products and some category pages work fine and load as they should. Here is an example of a few that work:

BUT other category pages never load and are all white:

If I remove the EG the page loads fine, so it is something to do with the EG. I did see it could be php settings in another post, here are mine:
allow_url_fopen = Off
allow_url_include = Off
display_errors = Off
enable_dl = Off
file_uploads = On
max_execution_time = 300
max_input_time = 600
max_input_vars = 5000
memory_limit = 1024M
post_max_size = 512M
session.gc_maxlifetime = 1440
session.save_path = “/var/cpanel/php/sessions/ea-php73”
upload_max_filesize = 256M
zlib.output_compression = Off

I have turned on error reporting for now. But the page never loads so no errors show.

Thanks for any help with this.

Hello Riceman,

Thank you for the detailed information. In most cases, a white screen could mean that there is a fatal error happening. Can you please enable the debug mode? You can do this by opening wp-config.php and adding

define('WP_DEBUG', true);

/* That's all, stop editing! Happy blogging. */

When you revisit the blank page, you should have some error output describing the issue in more detail. Please let us know the error message so that we can help you figure out what is causing the issue.

Best Regards.

Thanks, I do have it enabled, but still only a white page.

Hey Riceman.

That means your web host is not allowing error messages to be displayed despite enabling debugging in WordPress.

Please contact your web host to give you the error log. They can even fix their server if they see the error log so please let the web host fix their server also because after all, this is a server issue and not necessarily with Essential Grid. This just means that your web host is limited and could not run Essential Grid well.

You can also post the error log here in a Secure Note maybe we can lead you to the right direction.


Hi Riceman,

It seems that you are using the wrong slug to link your Product Categories, the URL should be In your given URL product-category was not there, it was our-products. I have also found that you have not added the Product Category into the menu item, I went ahead and added the option from Screen Options, and added a sample link. Please find the screenshot given below.

If you still want to use the Pages instead of the Product category and facing the same issue. I would suggest you check your Global Blocks which might be the reason behind your issue.

Hope it helps.

Hi, I own(rent from NameHero) the server. I run about 30 sites on this server. I have never had a problem on this server seeing the Error reporting from Wordpress on any of my sites. I dont think this is the issue. If you notice the page never fully loads… the loading icon for the page (in the browser tab) just spins and spins. It COULD be a resources setting on the server… I attached the php settings in case there was an issue there.

as for the Global Block being an issue. I have disabled the Global Block on this page:
and the issues is still there… white page, page never loads. The EG is the issue. If I disable the EG on a specific page, the page loads fine.

Yes, I want to use a specific page for the landing page of a category, not the category as you described. I need to load the EG on that page… the EG is the issue. If I disable the EG on a specific page, the page loads fine.

I DID narrow it down to the Essential Grid Source.

I am working on this page:
And this Grid:

If I select the 10" Offset Tag, the issue happens (white page). If I deselect the tag the page loads but with no product(there is only one right now). Please note that the tag is being used for a few different products in different Categories, but that shouldn’t make a difference as far as I know.
see screenshot
Here is the product name for your in case you need it: RV5 Extended Kingpin

Also note that in the EG Preview the grid works as it should, it just for some reason make a white page when loading from the front-end.
see screenshot

As a reference this page:
And this grid work Fine:

Please look into the detailed response above at your earliest convenience and let me know what you find. I really need to get this working in the next 24hrs.

Hi… is this one of those things that you could help me fix if I got the ONE subscription?

Hi Riceman,

A self reply will push the thread to the bottom of the forum, and that is why you are getting a delayed reply. The One is a newly launched service where the customization questions are answered. You can get more information on One from here:


Hi @coloradodesigngroup,

I apologize for the delay in getting back to you about this. I’ve checked your site and believe I’ve uncovered the source of the problem. This is one of the URLs that wasn’t working originally:

I checked the Essential Grid on that page and found the source was set to Post. I changed it to Product and now it is working again. Here’s a screenshot of what I changed:

You might just need check any other grids and make sure the sources are set to the right filtering criteria.

Well Holy Moly, we have been on a wild goos chase for such a simple mistake. Thanks so much for finding this…

Glad to hear this is solved now! Sometimes the answer can be so close, yet you need another pair of eyes to see it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.