Page Not Properly Loading


I have a page I’m trying to edit “” and I’m getting the spinning wheels when trying to edit part of it.

I have increased the the PHP Memory as another thread suggested using the code
define( ‘WP_MEMORY_LIMIT’, ‘256M’ );
define( ‘WP_MAX_MEMORY_LIMIT’, ‘512M’ );

And I’m still getting the spinning wheels when I scroll down the page to edit it.

Please advise how I can edit the page in Cornerstone.

Thanks, Mike

Hi @mikedoughty,

Thanks for writing in. Would you mind following the instructions below because there are the common solutions that could solve the problem.

  1. Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.

  2. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.

  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

  4. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  5. Remove custom CSS, Javascript and templates.

  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

If still not helping, please share us your admin credentials so we could check your setup closer.

Don’t forget to set it in a secure note.

Let us know how it goes.


Hi, I’ve gone through the process you mentioned. The issue is still occurring from what I can see.

Hi there,

Your site is currently using X 5.1.1. Kindly update to the latest version 5.2.5 to avoid issues.

You can also go over this article with some troubleshooting tips in case you are still having an issue after the update:

Hope this helps.


I’ve updated the Theme, and read the article, the issue is still persisting. I’m not using a ChildTheme, I have de-activated all of the plugins except Cornerstone.

How can I resolve the issue now?

Thanks, Mike

Hello Mike,

On my end Cornerstone is working absolutely fine. Please see screenshot. I request you to please clear browser cache and try loading again.



I have cleared the browser cache as suggested, however the problem still persists. The issue can be foudn when you scroll down about half way and further and you get the spinning wheel, which does not go away. This is how the issue has always been.

I’ve also tried it on different machines, and the same issue is evident, so can’t be due to browser cache on the other machines.

How can I get this resolved please

See screenshots below

Thanks, Mike

Hello Mike,

I can confirm that the error is still present. Could you please provide the ftp of your site. We want to manually update the theme to make sure that no files were corrupted during the updates.

Thank you in advance.

Login in Secre Note

Hi There,

I have investigated this issue further and I can see the following error on the console log.

Xfr request made by preview timed out

Could you please try increasing your PHP max_execution_time to 300 and see if that resolves your issue.

Let us know how it goes.


Thanks, I’ve added that to the htaccess file and the problem still persists.

What next?

Thanks, Mike

Hi there,

Are you on shared hosting? Could you try adding this to your site’s htaccess file

<ifModule mod_headers.c>
    Header set Connection keep-alive

Of if you’re on shared hosting, please contact your hosting provider as some of them may not allow it (which is why they turned it off). Without it, the preview will timeout or at least too slow.



Thanks, I’ve added that code as recommended, contact WPEngine, who confirm it is fine to add that code.

The issue continues to persist.

The page that is having the issue is a sales page, and I really need to be able to edit it, due to the fact I’ve driving PPC traffic to it.

How can I please resolve this issue?

Thanks, Mike

Hi there,

Till now, my colleagues tried to pinpoint the issue and ruled out many possible cases, that is why we need to double check the case for that specific page you are talking about.

I followed the steps below to add a new test page and use the template functionality of the Cornerstone to duplicate the page:

After that, add a test page and go to the Cornerstone and use the same template functionality, but this time to load the previously added template to the new one.

Then check the case and see if you still have the problem. If yes try then try to delete the sections one by one on that test page, save and go out of the Cornerstone and get back to check.

This will show if the problem exists in a specific section or not. If yes then you need to investigate further to find which element or code is causing the issue.

I already added the Test Page and added the Test Page template, you just need to load the template there and do the test mentioned above.

Regarding the necessity of doing changes on the sales page, I want to offer an alternative way to edit your page at the moment so it will not hurt your business. Kindly use the Skeleton mode at the moment to do your changes:

As a test, I added one additional ! to your headline and it worked ok:

So you can use the Skeleton mode to do the quick changes you need till you find out the cause of the preview fail.

Thank you for your cooperation.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.