Page content disappeared and can't insert templates

Hi there,

I’ve been working on a site since the release and it’s been fine. Have been using the layout builder with Custom Post Types and all running perfect.
I went to carry on working on it just now and the home and about page content has disappeared. It just shows the header and footer and not the content. When I log in and go to edit the page in Pro it shows a blank page. I had saved a version of the pages as a template but it doesn’t let me insert templates. Gives an ‘uh oh, failed to insert template’ error with all templates I try to add.

I’ve deactivated all plugins and caching and still getting the same issue.
Tried in Firefox (Was on Chrome) but still the same issue.
I upped the WP memory as suggested in a similar post but no luck.
I’ve tried adding new pages to add the templates there and nothing.

Only thing I can think that may have changed since I last worked on it was updating to 4.0.11 - though that’s not impacted any other sites. is the site.

Any thoughts would be great!

Hi @RubberDuckers,

Thanks for reaching out.

To better help you with your issue, we need to check your WordPress admin. To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Sure thing!

Hello @RubberDuckers,

Thanks for providing the information. I have logged in and it seems that you have edited the pages outside of the Pro Editor. Be aware that you are not supposed to switch between editors because it may corrupt the editor data which may no longer allow you to edit the page back in the Pro Editor. When this happens, it is best that you recreate the page from scratch because the data has been corrupted. Starting from scratch is way faster than going back and forth to figure out what has caused the issue or if the data can be reverted.

Best Regards.

Thanks for looking at it.

I hadn’t changed anything on the normal page editor. The only thing I ever change there is the featured image, page template and page name.
I’ve never had an issue on the countless other PRO sites doing this and if it’s something that may happen more in the future post the latest update, it’ll be pretty bad as it’d be quite easy for a client to accidentally do that and then starting from scratch isn’t good.
I may have for this to try troubleshoot post the problem happening.

And it doesn’t really explain why the templates don’t load on a new page? The page editor may be corrupted, sure, but the saved template…?

I can recreate but I still think it’s worth looking into.

Hello @RubberDuckers,

I can confirm that the templates cannot be loaded in your site. Please check your server configuration in Tools > Site Health > Info > Server. You may need to increase your Max Input Time to 300, the Upload Max Filesize and PHP Post Max size to 256MB. If this still does not help, provide us FTP access to your site so that we can check your settings. Please create a secure note with the following info:

  • FTP hostname
  • FTP username
  • FTP password

- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Thanks @ruenel

This is the server config:

Which seems to have the settings you suggest?

It’s using the same server config as all my other sites are with no issues.
I wonder if it’s worth trying rolling back to 4.0.10 in case it’s that?

But will add FTP details too.

It has been absolutely fine until I flagged this!

As a follow up - I can add templates from a page like ‘Contact’ which is one of the pages that work. But not from others.
I think you’re right in that it’s a re-create job, which is a shame/annoying and would be good to see what caused it to hopefully avoid it in the future!
Especially as it’s 2 pages not just the one.

Hello @RubberDuckers,

It could be that the page was edited outside of the editor by accident. This is mostly true is the issue only happens in one or two pages. And the best and fastest way is to recreate the page instead.

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.