Page Builder won't load after updating Pro

After updating to the latest version of Pro I can no longer edit pages, they either have the spinning loading icon forever or the below text displays:

image

I’ve cleared cache, disabled all plugins etc. The only other weird thing I notice is that when I’m on the website the Wordpress Admin bar’s drop down menus don’t work.

Site is at tools4change.co.uk

Hi @JSW88,

Thanks for reaching out.

When I tried to access your WordPress admin URL it redirects me to the homepage, please fix it so that we can help you troubleshoot your issue.

Hope that helps and let us know how it goes.

Thank you.

Hey @cramaton, I had a 404 redirect plugin, which is the only thing that I think might be doing that, so I’ve deactivated it.

Cheers!
Joe

Hello @JSW88,

I checked your site It seems that you have successfully updated the PRO theme by your self.

Glad that your issue has been fixed by your self.

Have a great day!
Thanks

Hey @PrakashS,

Thanks for your reply. The issue wasn’t updating the theme, it’s that I can no longer update any pages as the editor won’t load. Which is still the case unfortunately.

Hello @JSW88,

I have investigated your issue further and I found out that you have set the different Site Address URL and your index.php in your root directory may not have changed yet. You need to edit it and make sure to add the site directory in the code.

see the secure note.

I have temporarily corrected the Site Address so that you can access the Pro > Theme Options or edit the pages.

Best Regards.

Hey @ruenel, thanks for the reply!

My index.php file doesn’t have this line of code:
image

The whole of the file is:

Cheers,
Joe

Hi Joe,

What I found by investigating your site, that the specific Home Page is not loading into the Content builder, whereas other pages do.
I have created a testing page https://tools4change.co.uk/test-by-themeco/ and also duplicated the Home Page both loaded successfully in the Content Builder.
If you wish, you can continue with the duplicate page I have created from the Home page, otherwise, I would suggest you troubleshoot a few common issues:

  1. Testing for Plugin Conflict
  2. CSS/JS Customization
  3. Disabling Cache
  4. Child Theme Issue

Hope it helps.
Thanks

Hey @tristup,

Thank you. I’ve just set the duplicated home page as the homepage and unfortunately it won’t load in the content builder when it’s the homepage. Also I still can’t load any of the other pages in the Pro editor from the Wordpress pages area.

I’ve worked through those four points previously when trying to fix it too…

Hi Joe,

What I found that the WordPress Address and Site Address are different, which was fixed earlier by @runel.

By going ahead I fixed that again, which fixed the issue, and pages are started loading again in the builder.

Webp.net-resizeimage (3)

I would suggest you maintain the same URL for the site, especially in the following places to avoid these type of issue in the future:

  1. WordPress Address: in WordPress dashboard Settings > General
  2. Site Address: in WordPress dashboard Settings > General
  3. Themeco Account: to validate the license.

Thanks

Hey @tristup,

That wasn’t a fix, the website is installed to a subdirectory and is meant to load at tools4change.org not tools4change.org/site as per https://wordpress.org/support/article/giving-wordpress-its-own-directory/

I have other websites I’ve set up with the install folder not in the root directory that all work fine, and various errors still show up on this website even when it’s set up with both the Wordpress and Site address as the same:

Hi @JSW88,

Everything is loaded in our end and we can update everything. I suggest that you clear your browser cache or if you could give us a video showing that the builder is not loading on your end that would be great.

Hope that helps.

Thank you.

Hey @cramaton,

It’s not working for me, unfortunately:
ezgif.com-video-to-gif

Hello @JSW88,

Unlike my colleagues, I am experiencing the same as what you are having. Can you please provide FTP details so I can investigate the issue further?

Thank you in advance.

Hey @ruenel, thanks for your reply. I’ll post the credentials now.

Hi Joe,

The page builder is trying to access the files it required to load, from the available URL in Site Address i.e https://tools4change.co.uk but the files are not present there and that is the cause of the issue.

And If you are trying to install WordPress into sub-directory without changing the URL as per the https://wordpress.org/support/article/giving-wordpress-its-own-directory/. You also need to change your .htaccess file as described here: https://wordpress.org/support/article/giving-wordpress-its-own-directory/#method-i-without-url-change

Please let us know if that resolved the issue, if not we will start a further investigation on it.

Thanks