New install: The preview could not load due to misconfigured URLs

The preview could not load due to misconfigured URLs. This could happen if you are using multiple environments and the site URL was not updated after migrating.

Origin URL:
Preview URL: /

Nothing in there for preview… Not sure why?

After setting up a fresh WP install and installing PRO, we are seeing the above message… There is no import or anything… Just fresh out of the box… Any ideas?

Hello @disadmin,

Thanks for asking. :slight_smile:

Please refer following article for possible solution to the error message you are seeing. Also please note that in the same article we have added a special section for website is hosted on Siteground Staging server. In that regards if your website is hosted on Siteground Staging server, please try to implement the solution and let us know how it goes:


This is not on a Siteground Staging server… Its on a liquidweb server

Also, the site address and the WP address are the same in General–Settings

Hi There,

Is it possible to provide us with your WordPress login credentials to check this issue ? You can provide the following information in a secure note.

  • Site URL
  • WordPress credentials

Also make sure that you’re running PHP 5.6.32 or later to avoid incompatibility issues and try increasing PHP max execution time to 300.

PS: After a fresh installation, did you change your Permalink structure and set it to Postname ? If not, try changing it to post-name and then try to edit your pages before providing your login credentials.


Sent a secure note to you.

Its on the latest php. I’m not sure about the permalink structure part or how to change that

Hi There,

Upon checking, I’m getting the following error.
ERROR: Invalid username.

To check permalink settings, please head over to your Settings -> Permalinks section within your WordPress backend and then set the options Postname and save the changes and see if that helps.


sent another secure note…

The postname option is already checked. Thanks

Hi there,

It’s because of Root Relative URLs plugin, please disable it. Please note Wordpress URL configuration is always absolute and it’s intended that way. Making it relative will always cause issues.

It seems that you’re working on two different URL as well, and instead of creating a different instance, it’s the same instance with enforced new URL. It’s not gonna work since the internal URLs doesn’t match.

You have to create a dedicated staging site in which has its own absolute URL rather than forcing it.


I disabled that plugin and it broke the site… Went all to text.

We’ve done this the same way in the past and its worked… On the license page everything looks just like the ones that are working for us.

Where do you see two different URLS?

Hi there,

I see them in the loaded asset files, plus, in the error message.

The purpose of that plugin is converting all absolute URL to relative URL to make easier to migrate. Example,


If it’s migrated to then it will become without changing the domain at all. But again, it causes issues since Wordpress standard is based on absolute URL.


Hi there,

I’m not really sure either how and why it’s not working now, but I’m sure it’s due to URL as displayed by the error. Maybe the Root Relative URLs is failing now due to WP 4.9. There is nothing much change in our recent updates, it only contains MEJS fixes for WP 4.9, so maybe the culprit is within 4.9 updates which are affecting Root Relative URLs.

You may do these,

  1. Roll back to previous versions earlier than 4.9
  2. Or create your staging in different environment/host without a need for that plugin and make sure it has its own dedicated URL. You may use All in one migration plugin to do that and it will automatically handle internal URLs


We’re experiencing the same issue with one of our existing sites
It is currently using WordPress 4.8.4 running X Pro theme version 1.0.4 installed. Afraid to update to 1.1.0.

We added the latest Pro with Pro Child Theme and when that theme is activated, we get the same error message:
“The preview could not load due to misconfigured URLs. This could happen if you are using multiple environments and the site URL was not updated after migrating.”

Activating XPro theme, it allows us to make edits again.
Since we hadn’t updated that site to WP 4.9, that’s not the issue.

Hi there,

Our Pro theme and X theme using the Cornerstone plugin need the absolute URLs to show the preview correctly as it uses the home_url function to retrieve the assets.

As my colleague mentioned the WordPress built-in implementation also does that way. I’m afraid you will need to change the URL structure which you used and set the websites with only 1 URL without relative ones.

In addition to a point above, if you go to General > Settings page you should see both URLs be the same. If not it also will be another reason which you can not work with the Pro builder.

Thank you for your understanding.

Just checked - the dental website (see previous secure note) was built with XPro and does have matching URLs under General > Settings.
Once we try to implement the latest version of Pro as the Theme, it cannot display the preview to allow us to make site updates.
We have built several sites over the past year + using X/Cornerstone and then XPro. Our concern is that if we upgrade all to Pro, we’ll be unable to update out sites. WordPress 4.9 is ruled out as the culprit as teh dental site has not been updated to 4.9 yet - we’re now waiting to avoid adding another variable to the issue.

We set up the new sites in the same way we’ve been setting up all of our past X Theme/Cornerstone and XPro sites. The only problem we’ve had has been our most recent sites trying to set up Pro.

I’m not entirely sure where we’d change the URL structure of a site - we set up a development site which is essentially what you saw for the dental site URL, with the final URL being after dev.

We have yet another dev site that we need to set up - possibly today. What information do you need from that process to diagnose where things are suddenly going wrong for us?


Hi there,

Downgrading it back is just part of narrowing the issue, but I’m not saying it’s the actual issue. It could be due to a combination of multiple sources.

I recommend setting up a separate copy of your site in the different environment than you currently have now and make sure it doesn’t use relative URL and downgrade it to WP 4.8. Again, that is to narrow down our search, and by eliminating possible causes one at a time. Please provide us the new URL with login credentials when ready :slight_smile: , I really like to eliminate the relative URLs before we continue checking.


We created a new instance of WordPress which automatically included the Root Relative URLs plugin. Turning it off made even the basic theme break. We sleuthed it out with Liquid Web. We’re the first to bring it to their attention, we suspect not the last.

The URL in the db didn’t match the ones in the General >Settings, so somehow it’s not updating the db properly.

In PHP MyAdmin, we went wp_options in the db and updated both URL entries to match what it was supposed to be.

That allowed Pro to load and allow editing with the preview.

Thanks for your patience and assistance to narrow down the issue,.

Hi there,

Glad it’s working now and thanks for sharing. And you’re most welcome :wink:


I may have spoken too soon… the issue is back on the dental site. Re-checking and flushing caches… I’ll report any update in case it helps anyone else.

Let us know how it goes.