Nav anchors not working all the time


The website is
I have an issue with the nav anchors.
They work perfectly when accessed from another page.
For example, if you are here and click the “Work” link or “Process” in the nav, it jumps to the homepage to its anchor on the main page, but if you are already on the homepage and the “Work” or “Process” links are clicked, nothing happens, although it should scroll down to the respective link on the homepage, but nothing happens. I looked up some threads on the forum, but none seemed to be working.

Could you take a look at it and tell me what to do for this to work ok ?

Thanks a lot

Hi There @imokweb

Thanks for writing in! You need to enable one page navigation from your page settings.

Please refer to our detailed guide on how to setup one page navigation (

Hope that helps.

I added the one page navigation in the page options.
I cant seem to get it work.
I tried on 3 browsers, on firefox and chrome there is no luck, i also tried on epic privacy browser, which seems to be working perfectly, but that one is not being used by many people.
In chrome there is also another issue which appeared since the last update (yesterday)
These logos should be nicely aligned and fully visible.

Could you help me out with these?


Hi there,

You will have to create two menus for this. The first menu will be set as the Primary Menu.

Then for the custom URLs that are links to sections IDs, add the complete/absolute URLs for those sections.

Example: instead of just #learn.

This menu will be best as the menus for all the pages except those pages where one page navigation menu is active.

Then duplicate the menu that you will set to the pages are the one page navigation menu where you can set the URL to just the id of the section if the content is on the same page but place the absolute link if the section is on a different page. Make sure to set the menu in the one page navigation options which was previously suggested.

Hope this helps.

Did all that was suggested, created a copy of the menu called homepage menu, added the items, the page was set up to use this menu, now one has full link and the other one just #learn but neither seem to be working :).
Do you knwo what else could I do to make this happen?
Also could you tell me what to do with the logos to display normally?
Thank you

Hi @imokweb,

You have added the same ID in your section and your section’s row. Example, the learn ID.

Same goes for process

Please don’t use the same ID on other sections or row, it should be unique hence ID :slight_smile:


Hello again
The duplicate ids were removed
Still no luck :frowning:

Hi @imokweb,

Yes, I can confirm it in the builder that there are no duplicates anymore but I still see them through the code,

It will not work if it’s linking to multiple existences of an ID.

Perhaps your host has some sort of internal caching? It’s because the cache plugin is already inactive. I recommend turning off all possible cache feature and test it again.


There is the cloudflare, that cache was emptied. is what I see and the same for the process id, so now there is only one on the page, but it still doesnt work for me.

Do you have any idea why the logos are one above the other ?

Hi @imokweb,

Yes, ID’s are good now and seems to be working, BUT, it’s affected by one of the customization added to your child theme. I think it’s the header.php since it still contains an old code

<?php x_get_view( x_get_stack(), 'wp', 'header' ); ?>

and it’s supposed to be like this for the latest version

x_get_view( 'header', 'base' );

Please fix that and test it again, you can also confirm this issue by activating the parent theme instead of child theme, and it will start scrolling fluidly.

As for the logos, it looks okay on my end without overlaps. Perhaps it’s just not finished loading?


That was done also, but still nothing :slight_smile:
Do you have any other ideas what I might do, also do you have any idea what to do with the logos?

Hi @imokweb,

In that case, please install a fresh copy of the child theme, I checked and there are existing custom templates that may not compatible with the latest version.

As for the logos, I’m not sure what to recommend as the logos renders okay from my end. I just assumed it’s loading slow on your end.


Well exactly that is the issue with the logos, just now it rendered ok, then I hit hard refresh and I got this again
and I dont know what could be causing it.

Hi There,

Your website is slowing loading and it’s really hard for us to check the one page navigation.

We have an article about the optimize speed of your website:

I could also see that the logos are loading just fine on my end too:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.